aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
Commit message (Collapse)AuthorAgeFilesLines
* distcc: Change SRC_URIpyro-nextArmin Kuster2018-04-021-1/+1
| | | | | | | | | | | | | | | ERROR: distcc-3.2-r0 do_fetch: Fetcher failure: Unable to find revision d8b18df3e9dcbe4f092bed565835d3975e99432c in branch 3.2 even from upstream ERROR: distcc-3.2-r0 do_fetch: Fetcher failure for URL: 'git://github.com/distcc/distcc.git;branch=3.2'. Unable to fetch URL from any source. ERROR: distcc-3.2-r0 do_fetch: Function failed: base_do_fetch [v2] upstream deleted the branch and the hash no longer exists. Took the git snapshot from yocto and created a copy on my github. There was no offical 3.2 release, only rc versions. Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* e2fsprogs: fix compatibility with glibc 2.27Tanu Kaskinen2018-04-022-0/+63
| | | | | | | | | | | | | | | | | glibc 2.27 added function copy_file_range(), and e2fsprogs happens to have a different function with the same name. The conflict made e2fsprogs-native build fail. Here's a backport of a fix from upstream, the fix was released in e2fsprogs 1.43.8. The master branch doesn't need this fix, since it has new enough e2fsprogs version. At least rocko, pyro and morty need this, I haven't checked older stable branches. Apparently the problematic function was introduced in e2fsprogs version 1.43. Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* qemu: fix memfd_create with glibc 2.27Ross Burton2018-04-022-0/+58
| | | | | | | | | | glibc 2.27 has added memfd_create() but this conflicts with a copy in qemu, so take a patch from upstream to fix building with glibc 2.27. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* unfs3: Fix libtirpc usage for unfs3-native versionRichard Purdie2018-03-151-2/+2
| | | | Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* unfs3: Fix build with muslKhem Raj2018-03-152-3/+44
| | | | | | | | | Should also fix build on new build hosts where with glibc 2.27 rpc support is dropped in favor of libtirpc Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gcc: Remove patch causing ICE on x86_64 valgrind compileRichard Purdie2018-03-112-52/+0
| | | | | | | | | | | | | | | | | ../../valgrind-3.12.0/VEX/priv/host_ppc_isel.c: In function 'iselInt64Expr': | ../../valgrind-3.12.0/VEX/priv/host_ppc_isel.c:3270:1: internal compiler error: Segmentation fault | } | ^ | Please submit a full bug report, | with preprocessed source if appropriate. | See <http://gcc.gnu.org/bugs.html> for instructions. | rm -f libvexmultiarch-amd64-linux.a | Makefile:1813: recipe for target 'priv/libvex_amd64_linux_a-host_ppc_isel.o' failed Remove the patch to gcc causing this until the issue can be figured out. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gcc6: Backport few more patchesJuro Bystricky2018-03-1113-0/+7207
| | | | | | | | | Backported series of patches from https://github.com/hjl-tools/gcc.git branch /hjl/indirect/gcc-6-branch/master which contains an IA patch series for security related issues Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gcc6: enable FL_LPAE flag for armv7ve coresAndre McCurdy2018-03-112-0/+68
| | | | | | | | | | | | | | | | | | | | | | | The following commit added the FL_LPAE flag to FL_FOR_ARCH7VE, but neglected to also add it to the armv7ve compatible cores defined in arm-cores.def. https://github.com/gcc-mirror/gcc/commit/af2d9b9e58e8be576c53d94f30c48c68146b0c98 The result is that gcc 6.4 now refuses to allow -march=armv7ve and -mcpu=XXX to be used together, even when -mcpu is set to an armv7ve compatible core: arm-linux-gnueabi-gcc -march=armv7ve -mcpu=cortex-a7 -Werror ... error: switch -mcpu=cortex-a7 conflicts with -march=armv7ve switch [-Werror] Fix by defining flags for armv7ve compatible cores directly from FL_FOR_ARCH7VE, rather than re-creating the armv7ve flags independently by combining FL_FOR_ARCH7A with the armv7ve specific FL_THUMB_DIV and FL_ARM_DIV flags. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gcc7/gcc6: Fix unaligned STRD issue on ARMKhem Raj2018-03-112-0/+195
| | | | | | | | | | | | | | Backport https://gcc.gnu.org/bugzilla/show_bug.cgi?id=82445 Fixes [YOCTO 12297] Cherry-picked from oe-core master 568227133be3f9f015679df3525f6c4f86304fd0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 568227133be3f9f015679df3525f6c4f86304fd0) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gcc6: Upgrade to 6.4Khem Raj2018-03-1166-81/+24
| | | | | | | | Cherry-picked from oe-core master 7874fa86cb583fe6a178b95ead09430486197197 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gcc-6.3: Backport patch to fix ICE on ARMKhem Raj2018-03-112-0/+52
| | | | | | | | Fixes internal compiler error: Max. number of generated reload insns per insn is achieved (90) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gcc-runtime: Disable libitm on riscvKhem Raj2018-03-101-0/+2
| | | | | | | | Cherry-picked from oe-core master 21caa8bcda93ce67ef58548f7b85d0569d13d0b9 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* python3-nose: rename ${bindir}/nosetests into ${bindir}/nosetests3Denys Dmytriyenko2018-03-031-0/+4
| | | | | | | | | | | | | | | | This resolves a conflict when both python-nose and python3-nose are pulled into an image and try to install ${bindir}/nosetests binary. This matches with how other distros are solving this problem, e.g. Debian: https://packages.debian.org/jessie/all/python3-nose/filelist Also, other packages like python3-setuptools are already doing the same with their binaries. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* python3-setuptools: extend to nativesdkChen Qi2018-03-031-3/+4
| | | | | | | | | | | | | | Extend python3-setuptools to nativesdk because nativesdk-python3-pip needs it. Also, adjust RDEPENDS variable setting to keep the runtime dependencies for nativesdk package the same with the target one. The native package and the target package's dependencies remain the same as before. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* pax-utils: update SRC_URIMaxin B. John2018-03-031-2/+1
| | | | | | | | | | | | The gentoo.osuosl.org mirror doesn't store all versions of pax-utils, so use the maintainers own mirror which stores them all. Fixes [YOCTO #11559] (From OE-Core rev: 2f21725d68db1e76c8494522d6d4ca8a4aee080e) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* python3-native: Add python3-misc-native to RPROVIDESFabio Berton2018-01-201-0/+2
| | | | | | | | | | | | | OE-core commit 800753069f667cd1664d70b3779150c467e3b3fe remove RPROVIDES list to get runtime dependences from manifest file. python3-misc is added in python3 recipe, we need to add native runtime to use python3-misc with native recipes. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 31fd20811f6d11e7ed6ac84caf776ac46cd6fb6f) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* diffstat: use HTTP mirror for SRC_URIRoss Burton2018-01-071-1/+1
| | | | | | | | | | | | | | The Invisible Mirror FTP service is currently down, and FTP is horrible, so switch to the HTTP mirror. (cherry picked from commit f31461f8ea11e82dbe14454a1149d9ec2120404d) [YOCTO #12455] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* liburi-perl: update SRC_URI to yoctoproject mirrorChang Rebecca Swee Fun2018-01-071-1/+1
| | | | | | | | | | | | Upstream has removed the 1.71 release from www.cpan.org and moved to the latest 1.72. Since we don't want to upgrade at this point of time, temporarily move the SRC_URI to yoctoproject source mirror. [YOCTO #12454] Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9955Armin Kuster2017-12-1110-0/+1171
| | | | | | | | | Affects: <= 2.28 [v2] Fixed signed-off-by for CVE-2017-9955_9 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-9954Armin Kuster2017-12-112-0/+59
| | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Secuirty fix for CVE-2017-9756Armin Kuster2017-12-112-0/+51
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9755Armin Kuster2017-12-112-0/+64
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9753Armin Kuster2017-12-112-0/+80
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9752Armin Kuster2017-12-112-0/+209
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9751Armin Kuster2017-12-112-0/+3749
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* Binutils: Security fix for CVE-2017-9750Armin Kuster2017-12-112-0/+248
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-9749Armin Kuster2017-12-112-0/+78
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9748Armin Kuster2017-12-112-0/+47
| | | | | | affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9747Armin Kuster2017-12-112-0/+44
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security for fix CVE-2017-9746Armin Kuster2017-12-112-0/+92
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-9745Armin Kuster2017-12-112-0/+36
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix for CVE-2017-9744Armin Kuster2017-12-112-0/+47
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-9742Armin Kuster2017-12-112-0/+46
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-9040 and CVE-2017-9042Armin Kuster2017-12-112-0/+58
| | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-9039Armin Kuster2017-12-112-0/+62
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-9038 and CVE-2017-9044Armin Kuster2017-12-112-0/+52
| | | | Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix CVE-2017-8421Armin Kuster2017-12-112-0/+53
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix for CVE-2017-8398Armin Kuster2017-12-112-0/+148
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Secuirty fix CVE-2017-8396 and CVE-2017-8397Armin Kuster2017-12-112-0/+103
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Security fix CVE-2017-8395Armin Kuster2017-12-112-0/+73
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutls: Secuirty fix CVE-2017-8394Armin Kuster2017-12-112-0/+119
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix CVE-2017-8393Armin Kuster2017-12-112-0/+206
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security Fix CVE-2017-7614Armin Kuster2017-12-112-0/+104
| | | | | | Affects: <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* binutils: Security fix CVE-2017-7223Armin Kuster2017-12-112-0/+53
| | | | | | Affects <= 2.28 Signed-off-by: Armin Kuster <akuster808@gmail.com>
* gcc: Use libssp_nonshared linker specs only for ppc/muslFlorin Sarbu2017-12-113-29/+88
| | | | | | | | | | | Link libssp_nonshared.a only for ppc/musl because glibc already provides the content for libssp_nonshared in libc_nonshared.a and therefore we dont need to make it universal. (From OE-Core rev: c08247e3c7c004a40281d4010186a9ace86e0e47) Signed-off-by: Florin Sarbu <florin@resin.io> Signed-off-by: Armin Kuster <akuster@mvista.com>
* dpkg: Add missing RDEPENDS for dpkg-perlTom Rini2017-12-111-0/+19
| | | | | | | | | | | In order to be able to use dpkg-perl on a system various stock perl modules must also be installed on the system. Create the list of required modules based on a read of the code and testing with additional utilities and list them in RDEPENDS_${PN}-perl. Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* dpkg: Fix perl modules by moving them to the versioned perl directoryTom Rini2017-12-111-10/+4
| | | | | | | | | | | | In order for the dpkg perl modules to be used the must reside in the versioned perl library directory (as to be in the default include path). Be explicit about this location in our FILES_${PN}-perl directive, so that if this breaks in the future, the recipe will fail). We can now drop the custom do_configure as it wasn't fixing this problem. Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ruby: Security fix for CVE-2017-14064Armin Kuster2017-11-052-0/+354
| | | | | | affects ruby < 2.4.1 Signed-off-by: Armin Kuster <akuster@mvista.com>
* valgrind: enable on mips soft-floatAndré Draszik2017-11-051-2/+0
| | | | | | | | | | | | | | | | Valgrind support for mips soft-float hosts has been fixed in the 3.12 [1] and 3.13 [2] releases, so let's start building it on those, too. [1] https://sourceware.org/git/?p=valgrind.git;a=commit;h=8f0070d31daea6f0ed18f8fe69498a67530bfcbb [2] https://sourceware.org/git/?p=valgrind.git;a=commit;h=3172936d63da4b6257099bc05aee5793978269cb Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 82dbad6aa1390668aa86d28c8a3125b68d6072fa) Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* json-c: backport patch to fix gcc7 compilationAndré Draszik2017-11-052-0/+78
| | | | | | | | | | | | (The native version might be being built using gcc-7) We can't cherry-pick a commit from master, as master has upgraded json-c at the same time as applying this patch, see commit ccf630e78aad ("json-c: Upgrade to 0.12.1 release") Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>