aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu/files/use-g++-for-linking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/icu/files/use-g++-for-linking.patch')
-rw-r--r--meta/recipes-support/icu/files/use-g++-for-linking.patch74
1 files changed, 0 insertions, 74 deletions
diff --git a/meta/recipes-support/icu/files/use-g++-for-linking.patch b/meta/recipes-support/icu/files/use-g++-for-linking.patch
deleted file mode 100644
index f477dadee9..0000000000
--- a/meta/recipes-support/icu/files/use-g++-for-linking.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-Use g++ for linking.
-
-Upstream-Status: Inappropriate [Other]
-Build system specific
-
-Signed-off-by: Scott Garman <scott.a.garman@intel.com>
-
----
- tools/genccode/Makefile.in | 2 +-
- tools/gencmn/Makefile.in | 2 +-
- tools/genrb/Makefile.in | 2 +-
- tools/pkgdata/Makefile.in | 2 +-
- 4 files changed, 4 insertions(+), 4 deletions(-)
-
---- source.orig/tools/genccode/Makefile.in
-+++ source/tools/genccode/Makefile.in
-@@ -76,11 +76,11 @@ check-local: all-local
- Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) \
- && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
- $(TARGET) : $(OBJECTS)
-- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
-+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
-
-
- %.$(SECTION): $(srcdir)/%.$(SECTION).in
- cd $(top_builddir) \
- && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
---- source.orig/tools/gencmn/Makefile.in
-+++ source/tools/gencmn/Makefile.in
-@@ -76,11 +76,11 @@ check-local: all-local
- Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) \
- && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
- $(TARGET) : $(OBJECTS)
-- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
-+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
-
- %.$(SECTION): $(srcdir)/%.$(SECTION).in
- cd $(top_builddir) \
- && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
---- source.orig/tools/genrb/Makefile.in
-+++ source/tools/genrb/Makefile.in
-@@ -84,11 +84,11 @@ Makefile: $(srcdir)/Makefile.in $(top_b
-
- $(TARGET) : $(OBJECTS)
- $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
-
- $(DERB) : $(DERB_OBJ)
-- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
-+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
-
-
- # This line is needed to serialize builds when the gmake -j option is used.
- $(TARGET_STUB_NAME).$(SECTION): $(DERB_STUB_NAME).$(SECTION)
-
---- source.orig/tools/pkgdata/Makefile.in
-+++ source/tools/pkgdata/Makefile.in
-@@ -81,11 +81,11 @@ check-local: all-local
- Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) \
- && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
- $(TARGET) : $(OBJECTS)
-- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
-+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
-
-
- %.$(SECTION): $(srcdir)/%.$(SECTION).in
- cd $(top_builddir) \
- && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status