aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-config-gtk
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-config-gtk')
-rw-r--r--meta/recipes-sato/matchbox-config-gtk/files/no-handed.patch33
-rw-r--r--meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_svn.bb20
2 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-config-gtk/files/no-handed.patch b/meta/recipes-sato/matchbox-config-gtk/files/no-handed.patch
new file mode 100644
index 0000000000..9ab51ecedc
--- /dev/null
+++ b/meta/recipes-sato/matchbox-config-gtk/files/no-handed.patch
@@ -0,0 +1,33 @@
+Index: appearance/mb-appearance.c
+===================================================================
+--- appearance/mb-appearance.c (revision 1614)
++++ appearance/mb-appearance.c (working copy)
+@@ -300,11 +300,13 @@
+ gtk_font_button_set_font_name (GTK_FONT_BUTTON (font_button),
+ gconf_value_get_string (value));
+ } else if (strcmp (key, HANDED_KEY) == 0) {
++#if 0
+ GEnumValue *e;
+ e = g_enum_get_value_by_name (g_type_class_ref (GTK_TYPE_CORNER_TYPE),
+ gconf_value_get_string (value));
+ gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (handed_check),
+ e->value == GTK_CORNER_TOP_RIGHT);
++#endif
+ }
+ }
+
+@@ -395,12 +397,13 @@
+ gtk_container_add (GTK_CONTAINER (align), font_button);
+
+ /* Left/Right Handed */
+-
++#if 0
+ frame = new_frame (_("Orientation"), &align);
+ gtk_box_pack_start (GTK_BOX (box), frame, TRUE, TRUE, 0);
+ handed_check = gtk_check_button_new_with_mnemonic (_("_Left-handed"));
+ g_signal_connect (handed_check, "toggled", G_CALLBACK (on_handed_set), NULL);
+ gtk_container_add (GTK_CONTAINER (align), handed_check);
++#endif
+
+ gconf_client_add_dir (gconf, INTERFACE_DIR, GCONF_CLIENT_PRELOAD_ONELEVEL, NULL);
+ g_signal_connect (gconf, "value-changed", G_CALLBACK (on_gconf_value_changed), NULL);
diff --git a/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_svn.bb b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_svn.bb
new file mode 100644
index 0000000000..af748f14ff
--- /dev/null
+++ b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Matchbox GTK+ theme configuration application."
+HOMEPAGE = "http://matchbox-project.org"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://appearance/mb-appearance.c;endline=25;md5=ea92333cf8a6802639d62d874c114a28"
+
+DEPENDS = "gconf gtk+"
+RDEPENDS = "settings-daemon"
+
+PV = "0.0+svnr${SRCREV}"
+
+S = "${WORKDIR}/${PN}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://no-handed.patch;patch=1;pnum=0"
+
+inherit autotools pkgconfig
+