aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_0.83.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.83.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.83.bb b/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
new file mode 100644
index 0000000000..78d51b3f99
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Real-Time preemption testcases"
+HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
+SECTION = "tests"
+DEPENDS = "linux-libc-headers eglibc"
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=ce162fe491d19d2ec67dff6dbc938d50 \
+ file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
+# Version v0.83
+SRCREV = "5f1e84f8b015df3ff950056494134eca3f640d70"
+
+# git -> 0.83 needs a PE bump
+PE = "1"
+
+SRC_URI = "git://github.com/clrkwllms/rt-tests.git"
+
+S = "${WORKDIR}/git"
+
+CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnulli ${LDFLAGS}"
+
+# calling 'uname -m' is broken on crossbuilds
+EXTRA_OEMAKE = "NUMA=0"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
+ INCLUDEDIR=${includedir}
+}