aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel')
-rwxr-xr-xmeta/recipes-kernel/lttng/lttng-tools/run-ptest4
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools/runtest.patch52
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb8
3 files changed, 62 insertions, 2 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools/run-ptest b/meta/recipes-kernel/lttng/lttng-tools/run-ptest
new file mode 100755
index 0000000000..e758815c77
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-tools/run-ptest
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+make -C tests installcheck
+
diff --git a/meta/recipes-kernel/lttng/lttng-tools/runtest.patch b/meta/recipes-kernel/lttng/lttng-tools/runtest.patch
new file mode 100644
index 0000000000..545a5dc083
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-tools/runtest.patch
@@ -0,0 +1,52 @@
+diff --git a/Makefile.am b/Makefile.am
+index 584f59b..c2bcabd 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -12,3 +12,9 @@ dist_doc_DATA = LICENSE \
+ dist_noinst_DATA = CodingStyle
+
+ EXTRA_DIST = extras/lttng-bash_completion gpl-2.0.txt lgpl-2.1.txt
++
++install-ptest:
++ cp -r $(srcdir)/tests $(DESTDIR)
++ for m in $$(find $(DESTDIR)/tests -name Makefile); do \
++ sed -i -e 's|^Makefile:|_Makefile:|' $$m; \
++ done
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6d5b00d..3774f9d 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -1,14 +1,17 @@
+ SUBDIRS = utils regression unit stress
+
+-if USE_PYTHON
+-check-am:
++installcheck-am:
+ ./run.sh unit_tests
+ ./run.sh fast_regression
++if USE_PYTHON
+ ./run.sh with_bindings_regression
+-else
++endif
++
+ check-am:
+ ./run.sh unit_tests
+ ./run.sh fast_regression
++if USE_PYTHON
++ ./run.sh with_bindings_regression
+ endif
+
+ dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+diff --git a/tests/run.sh b/tests/run.sh
+index c6c50fd..6455359 100755
+--- a/tests/run.sh
++++ b/tests/run.sh
+@@ -19,4 +19,7 @@
+
+ [ -z "$1" ] && echo "Error: No testlist. Please specify a testlist to run." && exit 1
+
+-prove --merge --exec '' - < $1
++prove --merge -v --exec '' - < $1 | sed \
++ -e 's|^ok \(.*\)|PASS: \1|' \
++ -e 's|^not ok \(.*\)|FAIL: \1|' \
++ | egrep -h 'PASS|FAIL'
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
index 2e0ee15a29..4322027d7d 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
@@ -10,15 +10,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \
file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca"
DEPENDS = "liburcu popt lttng-ust"
+RDEPENDS_${PN}-ptest += "make"
SRCREV = "c9dc1289e040c542f96fbfd558267786816d5703"
PV = "v2.3.0"
-SRC_URI = "git://git.lttng.org/lttng-tools.git"
+SRC_URI = "git://git.lttng.org/lttng-tools.git \
+ file://runtest.patch \
+ file://run-ptest \
+ "
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools ptest
export KERNELDIR="${STAGING_KERNEL_DIR}"