aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_1.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
new file mode 100644
index 0000000000..c52f2830b8
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_1.13.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.lesswatts.org/"
+BUGTRACKER = "http://bugzilla.lesswatts.org/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "virtual/libintl ncurses"
+
+# powertop 1.13 needs lspci
+REPENDS_${PN} = "pciutils"
+
+PR = "r0"
+
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
+
+CFLAGS += "${LDFLAGS}"
+EXTRA_OEMAKE = "VERSION=\"${PV}\""
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+