aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_1.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
index 472a2bbcff..b08f65c684 100644
--- a/meta/recipes-kernel/powertop/powertop_1.13.bb
+++ b/meta/recipes-kernel/powertop/powertop_1.13.bb
@@ -11,16 +11,19 @@ DEPENDS = "virtual/libintl ncurses"
# powertop 1.13 needs lspci
RDEPENDS_${PN} = "pciutils"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
- file://stub_out_the_ncurses_calls_in_dump_mode.patch"
+ file://stub_out_the_ncurses_calls_in_dump_mode.patch \
+ "
SRC_URI[md5sum] = "78aa17c8f55178004223bf236654298e"
SRC_URI[sha256sum] = "2bc866089496877dd26d2d316ad5763ab8ecb5e28aefba44bc5d355dcdc58d98"
CFLAGS += "${LDFLAGS}"
-EXTRA_OEMAKE = "VERSION=\"${PV}\""
+EXTRA_OEMAKE = "VERSION=\"${PV}\" EXTRA_LIBS=${EXTRA_LIBS}"
+
+EXTRA_LIBS_libc-uclibc = "-lintl"
inherit update-alternatives
ALTERNATIVE_NAME = "powertop"
@@ -30,7 +33,7 @@ ALTERNATIVE_PRIORITY = "100"
do_configure() {
# We do not build ncurses with wide char support
- sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+ sed -i -e 's:lncursesw:lncurses ${EXTRA_LIBS}:g' ${S}/Makefile
}
do_install() {