aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofileui-server_git.bb')
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
index 200bab3b24..70a1fbf9c3 100644
--- a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -6,7 +6,8 @@ PV = "0.0+git${SRCPV}"
S = "${WORKDIR}/git"
SRC_URI = "git://git.yoctoproject.org/oprofileui \
- file://init"
+ file://init \
+ file://oprofileui-server.service "
EXTRA_OECONF += "--disable-client --enable-server"
@@ -15,9 +16,17 @@ RDEPENDS_${PN} = "oprofile"
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/oprofileui-server
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/oprofileui-server.service ${D}${systemd_unitdir}/system/
+ sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
+ -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/oprofileui-server.service
}
+inherit update-rc.d systemd
+
INITSCRIPT_NAME = "oprofileui-server"
INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."
-inherit update-rc.d
+SYSTEMD_SERVICE_${PN} = "oprofileui-server.service"
+SYSTEMD_AUTO_ENABLE = "disable"