aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/scripts-Makefile.headersinst-install-headers-from-sc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux-libc-headers/linux-libc-headers/scripts-Makefile.headersinst-install-headers-from-sc.patch')
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers/scripts-Makefile.headersinst-install-headers-from-sc.patch23
1 files changed, 11 insertions, 12 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/scripts-Makefile.headersinst-install-headers-from-sc.patch b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/scripts-Makefile.headersinst-install-headers-from-sc.patch
index be1ef2502f..9bc59823a3 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/scripts-Makefile.headersinst-install-headers-from-sc.patch
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers/scripts-Makefile.headersinst-install-headers-from-sc.patch
@@ -16,24 +16,26 @@ argument size and install headers in a long path name environment.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
---
+RP: Refreshed for 3.10 as the problem still exists there on the autobuilders
+
scripts/Makefile.headersinst | 4 +++-
1 files changed, 3 insertions(+), 1 deletions(-)
-diff --git a/scripts/Makefile.headersinst b/scripts/Makefile.headersinst
-index 06ba4a7..536d722 100644
---- a/scripts/Makefile.headersinst
-+++ b/scripts/Makefile.headersinst
-@@ -71,7 +71,7 @@ printdir = $(patsubst $(INSTALL_HDR_PATH)/%/,%,$(dir $@))
+Index: linux-3.10/scripts/Makefile.headersinst
+===================================================================
+--- linux-3.10.orig/scripts/Makefile.headersinst
++++ linux-3.10/scripts/Makefile.headersinst
+@@ -72,7 +72,7 @@ printdir = $(patsubst $(INSTALL_HDR_PATH
quiet_cmd_install = INSTALL $(printdir) ($(words $(all-files))\
file$(if $(word 2, $(all-files)),s))
cmd_install = \
-- $(PERL) $< $(installdir) $(SRCARCH) $(input-files); \
-+ xargs $(PERL) $< $(installdir) $(SRCARCH) < $(INSTALL_HDR_PATH)/.input-files; \
+- $(CONFIG_SHELL) $< $(installdir) $(input-files); \
++ xargs $(CONFIG_SHELL) $< $(installdir) < $(INSTALL_HDR_PATH)/.input-files; \
for F in $(wrapper-files); do \
echo "\#include <asm-generic/$$F>" > $(installdir)/$$F; \
done; \
-@@ -100,7 +100,9 @@ targets += $(install-file)
- $(install-file): scripts/headers_install.pl $(input-files) FORCE
+@@ -101,7 +101,9 @@ targets += $(install-file)
+ $(install-file): scripts/headers_install.sh $(input-files) FORCE
$(if $(unwanted),$(call cmd,remove),)
$(if $(wildcard $(dir $@)),,$(shell mkdir -p $(dir $@)))
+ @echo $(input-files) > $(INSTALL_HDR_PATH)/.input-files
@@ -42,6 +44,3 @@ index 06ba4a7..536d722 100644
else
__headerscheck: $(subdirs) $(check-file)
---
-1.7.0.4
-