summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch')
-rw-r--r--meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch b/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
deleted file mode 100644
index d39270a48b..0000000000
--- a/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Compile with uclibc
-
-Upstream-Status: Pending
----
- configure.ac | 3 +++
- src/glsl/strtod.c | 2 +-
- src/mesa/main/imports.c | 2 +-
- 3 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index fbaa376..454dad2 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -543,6 +543,9 @@ AC_SUBST([DLOPEN_LIBS])
- dnl See if posix_memalign is available
- AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
-
-+dnl See if newlocale is available
-+AC_CHECK_FUNCS_ONCE(newlocale)
-+
- dnl SELinux awareness.
- AC_ARG_ENABLE([selinux],
- [AS_HELP_STRING([--enable-selinux],
-diff --git a/src/glsl/strtod.c b/src/glsl/strtod.c
-index a876e13..9fce7e9 100644
---- a/src/glsl/strtod.c
-+++ b/src/glsl/strtod.c
-@@ -45,7 +45,7 @@ double
- glsl_strtod(const char *s, char **end)
- {
- #if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && \
-- !defined(__HAIKU__)
-+ !defined(__HAIKU__) && defined (HAVE_NEWLOCALE)
- static locale_t loc = NULL;
- if (!loc) {
- loc = newlocale(LC_CTYPE_MASK, "C", NULL);
-diff --git a/src/mesa/main/imports.c b/src/mesa/main/imports.c
-index d3727ef..363bf32 100644
---- a/src/mesa/main/imports.c
-+++ b/src/mesa/main/imports.c
-@@ -767,7 +767,7 @@ float
- _mesa_strtof( const char *s, char **end )
- {
- #if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && \
-- !defined(ANDROID) && !defined(__HAIKU__)
-+ !defined(ANDROID) && !defined(__HAIKU__) && defined (HAVE_NEWLOCALE)
- static locale_t loc = NULL;
- if (!loc) {
- loc = newlocale(LC_CTYPE_MASK, "C", NULL);
---
-1.7.10.4
-