aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter')
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0.inc56
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0_1.14.4.bb7
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.14/enable_tests.patch (renamed from meta/recipes-graphics/clutter/clutter/enable_tests.patch)12
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.8_1.8.4.bb23
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.8_git.bb20
-rw-r--r--meta/recipes-graphics/clutter/clutter-fpu.inc6
-rw-r--r--meta/recipes-graphics/clutter/clutter-package.inc2
-rw-r--r--meta/recipes-graphics/clutter/clutter.inc23
-rw-r--r--meta/recipes-graphics/clutter/clutter/build-fix.patch18
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch42
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch52
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch34
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch15
-rw-r--r--meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch34
-rw-r--r--meta/recipes-graphics/clutter/clutter/symconflict.patch33
-rw-r--r--meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch68
-rw-r--r--meta/recipes-graphics/clutter/clutter/update_gettext_macro_version.patch32
17 files changed, 70 insertions, 407 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-1.0.inc b/meta/recipes-graphics/clutter/clutter-1.0.inc
new file mode 100644
index 0000000000..6710776213
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-1.0.inc
@@ -0,0 +1,56 @@
+DESCRIPTION = "Clutter graphics library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPLv2.1+"
+
+inherit clutter
+
+SRC_URI += "file://enable_tests.patch"
+
+DEPENDS = "gtk-doc-native pango glib-2.0 json-glib atk udev cogl-1.0"
+PACKAGES =+ "${PN}-examples"
+AUTOTOOLS_AUXDIR = "${S}/build"
+
+EDEPENDS_X11 = "virtual/libx11 libxi libxfixes"
+EDEPENDS_GLX = "virtual/libgl"
+EDEPENDS_EGL = "virtual/egl"
+
+EDEPENDS_EVDEV = "libxkbcommon"
+ERDEPENDS_EVDEV = "xkeyboard-config"
+
+# Disable pretty much everything, override in platform specific set up
+EXTRA_OECONF += "--disable-gtk-doc \
+ ${@get_fpu_setting(bb, d)} \
+ --disable-introspection \
+ --disable-egl-backend \
+ --disable-quartz-backend \
+ --disable-win32-backend \
+ --disable-x11-backend \
+ --disable-gdk-backend \
+ --disable-wayland-backend \
+ --disable-wayland-compositor \
+ --disable-cex100-backend \
+ --disable-tslib-input \
+ --disable-evdev-input \
+ "
+
+PACKAGECONFIG[x11] = "--enable-x11-backend,,${EDEPENDS_X11}"
+PACKAGECONFIG[glx] = "--enable-x11-backend,,${EDEPENDS_X11} ${EDEPENDS_GLX}"
+PACKAGECONFIG[egl] = "--enable-egl-backend,,${EDEPENDS_EGL}"
+PACKAGECONFIG[evdev] = "--enable-evdev-input,,${EDEPENDS_EVDEV},${ERDEPENDS_EVDEV}"
+
+# Default configuration, distros might want to override
+PACKAGECONFIG ??= "glx"
+
+FILES_${PN}-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
+
+do_configure_prepend() {
+ # Fix up some weirdness in the docs
+ sed -i s:doc/reference/Makefile::g ${S}/configure.ac
+ sed -i s:doc::g ${S}/Makefile.am
+
+ # see https://bugzilla.gnome.org/show_bug.cgi?id=661128 for this
+ touch -t 200001010000 po/clutter-1.0.pot
+
+ # Disable DOLT
+ sed -i -e 's/^DOLT//' ${S}/configure.ac
+}
diff --git a/meta/recipes-graphics/clutter/clutter-1.0_1.14.4.bb b/meta/recipes-graphics/clutter/clutter-1.0_1.14.4.bb
new file mode 100644
index 0000000000..35824c60b5
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-1.0_1.14.4.bb
@@ -0,0 +1,7 @@
+
+require clutter-1.0.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[archive.md5sum] = "c072e4c27e69368f2b877ea4f6da2cdf"
+SRC_URI[archive.sha256sum] = "c996d91fff6fff24d9e23dcd545439ebc6b999fb1cf9ee44c28ca54c49c0ee1c"
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests.patch b/meta/recipes-graphics/clutter/clutter-1.14/enable_tests.patch
index 480b208cc7..f97d598090 100644
--- a/meta/recipes-graphics/clutter/clutter/enable_tests.patch
+++ b/meta/recipes-graphics/clutter/clutter-1.14/enable_tests.patch
@@ -1,10 +1,12 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
+Make tests installable
+
+The test applications are useful for image testing.
+
+Imported from clutter 1.8 package, git://git.openembedded.org/openembedded,
+commit ae28ee3f7a060b9e0d13154a84f2444a98490b5b, updated patch header.
Upstream-Status: Inappropriate [configuration]
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
Index: git/tests/interactive/Makefile.am
===================================================================
diff --git a/meta/recipes-graphics/clutter/clutter-1.8_1.8.4.bb b/meta/recipes-graphics/clutter/clutter-1.8_1.8.4.bb
deleted file mode 100644
index aceef967ea..0000000000
--- a/meta/recipes-graphics/clutter/clutter-1.8_1.8.4.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-require recipes-graphics/clutter/clutter.inc
-require recipes-graphics/clutter/clutter-package.inc
-
-PR = "r2"
-
-# We're API/ABI compatible and this may make things easier for layers
-PROVIDES += "clutter-1.6"
-
-PACKAGES =+ "${PN}-examples"
-FILES_${PN}-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
-
-SRC_URI = "http://source.clutter-project.org/sources/clutter/1.8/clutter-${PV}.tar.bz2 \
- file://enable_tests-1.4.patch \
- file://update_gettext_macro_version.patch"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-# because we've namespaced PN to clutter-1.8
-S = "${WORKDIR}/clutter-${PV}"
-
-BASE_CONF += "--disable-introspection"
-
-SRC_URI[md5sum] = "487f70f9b59e1328b47f1db4094ab662"
-SRC_URI[sha256sum] = "0d567177facd6913ac9c894e230ae48933125f02354ef965bbbf0586f1f0df91"
diff --git a/meta/recipes-graphics/clutter/clutter-1.8_git.bb b/meta/recipes-graphics/clutter/clutter-1.8_git.bb
deleted file mode 100644
index 89d8026201..0000000000
--- a/meta/recipes-graphics/clutter/clutter-1.8_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-require clutter.inc
-require clutter-package.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-
-# the 1.8.4 tag
-SRCREV = "f2183fa8df3d173afbee09cc4230ab8f4e03f459"
-PV = "1.8.4+git${SRCPV}"
-PR = "r2"
-
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "git://git.gnome.org/clutter;protocol=git;branch=master \
- file://enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch;rev=654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673 \
- file://enable_tests.patch;notrev=654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673 "
-S = "${WORKDIR}/git"
-
-BASE_CONF += "--disable-introspection"
-
-AUTOTOOLS_AUXDIR = "${S}/build"
diff --git a/meta/recipes-graphics/clutter/clutter-fpu.inc b/meta/recipes-graphics/clutter/clutter-fpu.inc
deleted file mode 100644
index c541fe3151..0000000000
--- a/meta/recipes-graphics/clutter/clutter-fpu.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-
-def get_clutter_fpu_setting(bb, d):
- if d.getVar('TARGET_FPU', True) in [ 'soft' ]:
- return "--without-fpu"
- return ""
-
diff --git a/meta/recipes-graphics/clutter/clutter-package.inc b/meta/recipes-graphics/clutter/clutter-package.inc
deleted file mode 100644
index 22993ffd01..0000000000
--- a/meta/recipes-graphics/clutter/clutter-package.inc
+++ /dev/null
@@ -1,2 +0,0 @@
-PACKAGES =+ "clutter-examples"
-FILES_clutter-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
diff --git a/meta/recipes-graphics/clutter/clutter.inc b/meta/recipes-graphics/clutter/clutter.inc
deleted file mode 100644
index 5a912afbac..0000000000
--- a/meta/recipes-graphics/clutter/clutter.inc
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Clutter graphics library"
-HOMEPAGE = "http://www.clutter-project.org/"
-LICENSE = "LGPLv2.1+"
-
-# Internal json-glib was removed in Clutter 1.5.2, cogl was removed in 1.8, atk required since 1.8
-STDDEPENDS = "virtual/libx11 pango glib-2.0 libxfixes libxi json-glib cogl atk"
-BASE_CONF = "${@get_clutter_fpu_setting(bb, d)}"
-
-DEPENDS = "${STDDEPENDS} virtual/libgl libdrm"
-EXTRA_OECONF = "${BASE_CONF} --with-flavour=glx"
-
-FILESPATH = "${FILE_DIRNAME}/clutter"
-
-inherit autotools pkgconfig gtk-doc gettext
-
-#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
-require clutter-fpu.inc
-
-#Fix up some weirdness in the docs
-do_configure_prepend() {
- sed -i s:doc/reference/Makefile::g ${S}/configure.ac
- sed -i s:doc::g ${S}/Makefile.am
-}
diff --git a/meta/recipes-graphics/clutter/clutter/build-fix.patch b/meta/recipes-graphics/clutter/clutter/build-fix.patch
deleted file mode 100644
index 08c1845dfa..0000000000
--- a/meta/recipes-graphics/clutter/clutter/build-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Installing the same file twice causes an error in Automake 1.11
-
-JL 19/03/10
-
-Upstream-Status: Pending
-
-Index: git/clutter/Makefile.am
-===================================================================
---- git.orig/clutter/Makefile.am 2010-03-19 11:37:51.000000000 +0000
-+++ git/clutter/Makefile.am 2010-03-19 11:50:46.744042007 +0000
-@@ -219,7 +219,6 @@
- $(source_h) \
- clutter-json.h \
- clutter-enum-types.h \
-- clutter-version.h \
- clutter.h
-
- DISTCLEANFILES = \
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
deleted file mode 100644
index 8cff0c5fe5..0000000000
--- a/meta/recipes-graphics/clutter/clutter/enable_tests-0.6.patch
+++ /dev/null
@@ -1,42 +0,0 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: clutter-0-6/tests/Makefile.am
-===================================================================
---- clutter.orig/tests/Makefile.am 2007-11-06 12:29:17.000000000 +0000
-+++ clutter-0-6/tests/Makefile.am 2007-11-06 12:30:11.000000000 +0000
-@@ -1,4 +1,4 @@
--noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
-+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
- test-actors test-behave test-text test-entry test-project \
- test-boxes test-perspective test-rotate test-depth \
- test-threads test-timeline test-score test-script
-@@ -26,4 +26,9 @@ test_timeline_SOURCES = test-timeline.c
- test_score_SOURCES = test-score.c
- test_script_SOURCES = test-script.c
-
-+test_textdir = $(pkgdatadir)
-+test_text_DATA = test-text.c
-+test_actorsdir = $(pkgdatadir)
-+test_actors_DATA = redhand.png
-+
- EXTRA_DIST = redhand.png test-script.json
-Index: clutter-0-6/tests/test-actors.c
-===================================================================
---- clutter.orig/tests/test-actors.c 2007-11-06 12:29:17.000000000 +0000
-+++ clutter-0-6/tests/test-actors.c 2007-11-06 12:29:21.000000000 +0000
-@@ -143,7 +143,7 @@ main (int argc, char *argv[])
- stage = clutter_stage_get_default ();
- clutter_actor_set_size (stage, 800, 600);
-
-- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
-+ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
-
- if (!pixbuf)
- g_error("pixbuf load failed");
-
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch
deleted file mode 100644
index d3c196fd83..0000000000
--- a/meta/recipes-graphics/clutter/clutter/enable_tests-0.8.patch
+++ /dev/null
@@ -1,52 +0,0 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: clutter/tests/Makefile.am
-===================================================================
---- clutter.orig/tests/Makefile.am 2008-06-26 16:46:26.000000000 +0100
-+++ clutter/tests/Makefile.am 2008-06-26 16:46:50.000000000 +0100
-@@ -1,4 +1,4 @@
--noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
-+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
- test-actors test-behave test-text test-entry test-project \
- test-perspective test-rotate test-depth \
- test-threads test-timeline test-timeline-dup-frames \
-@@ -17,8 +17,8 @@
- test-invariants
-
- if X11_TESTS
--noinst_PROGRAMS += test-pixmap
--noinst_PROGRAMS += test-devices
-+bin_PROGRAMS += test-pixmap
-+bin_PROGRAMS += test-devices
- endif
-
- INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter
-@@ -73,4 +73,9 @@
- test_invariants_SOURCES = test-invariants.c
- test_devices_SOURCES = test-devices.c
-
-+test_textdir = $(pkgdatadir)
-+test_text_DATA = test-text.c
-+test_actorsdir = $(pkgdatadir)
-+test_actors_DATA = redhand.png
-+
- EXTRA_DIST = redhand.png test-script.json
-Index: clutter/tests/test-actors.c
-===================================================================
---- clutter.orig/tests/test-actors.c 2008-06-26 16:46:26.000000000 +0100
-+++ clutter/tests/test-actors.c 2008-06-26 16:46:31.000000000 +0100
-@@ -195,7 +195,7 @@
- /* Create a texture from file, then clone in to same resources */
- if (i == 0)
- {
-- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
-+ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
- &error)) == NULL)
- {
- g_error ("image load failed: %s", error->message);
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch
deleted file mode 100644
index 16460b1a11..0000000000
--- a/meta/recipes-graphics/clutter/clutter/enable_tests-1.0.patch
+++ /dev/null
@@ -1,34 +0,0 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: git/tests/interactive/Makefile.am
-===================================================================
---- git.orig/tests/interactive/Makefile.am 2009-03-12 11:01:36.000000000 +0000
-+++ git/tests/interactive/Makefile.am 2009-03-12 11:04:12.000000000 +0000
-@@ -77,7 +77,7 @@
- AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
- AM_LDFLAGS = $(CLUTTER_LIBS)
-
--noinst_PROGRAMS = test-interactive
-+bin_PROGRAMS = test-interactive
-
- test_interactive_SOURCES = \
- test-main.c \
-Index: git/tests/interactive/test-actors.c
-===================================================================
---- git.orig/tests/interactive/test-actors.c 2009-03-12 11:01:36.000000000 +0000
-+++ git/tests/interactive/test-actors.c 2009-03-12 11:06:32.000000000 +0000
-@@ -182,7 +182,7 @@
- oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
- oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
-
-- real_hand = clutter_texture_new_from_file ("redhand.png", &error);
-+ real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
- if (real_hand == NULL)
- {
- g_error ("image load failed: %s", error->message);
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch
deleted file mode 100644
index 2ff76976f4..0000000000
--- a/meta/recipes-graphics/clutter/clutter/enable_tests-1.4.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-Index: git/tests/interactive/Makefile.am
-===================================================================
---- git.orig/tests/interactive/Makefile.am 2011-01-28 14:06:29.000000000 +0800
-+++ git/tests/interactive/Makefile.am 2011-01-28 14:26:59.000000000 +0800
-@@ -107,7 +107,7 @@
-
- common_ldadd = $(top_builddir)/clutter/libclutter-@CLUTTER_SONAME_INFIX@-@CLUTTER_API_VERSION@.la
-
--noinst_PROGRAMS = test-interactive
-+bin_PROGRAMS = test-interactive
-
- test_interactive_SOURCES = test-main.c $(UNIT_TESTS)
- test_interactive_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
diff --git a/meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch b/meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch
deleted file mode 100644
index 16460b1a11..0000000000
--- a/meta/recipes-graphics/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch
+++ /dev/null
@@ -1,34 +0,0 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: git/tests/interactive/Makefile.am
-===================================================================
---- git.orig/tests/interactive/Makefile.am 2009-03-12 11:01:36.000000000 +0000
-+++ git/tests/interactive/Makefile.am 2009-03-12 11:04:12.000000000 +0000
-@@ -77,7 +77,7 @@
- AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
- AM_LDFLAGS = $(CLUTTER_LIBS)
-
--noinst_PROGRAMS = test-interactive
-+bin_PROGRAMS = test-interactive
-
- test_interactive_SOURCES = \
- test-main.c \
-Index: git/tests/interactive/test-actors.c
-===================================================================
---- git.orig/tests/interactive/test-actors.c 2009-03-12 11:01:36.000000000 +0000
-+++ git/tests/interactive/test-actors.c 2009-03-12 11:06:32.000000000 +0000
-@@ -182,7 +182,7 @@
- oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
- oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
-
-- real_hand = clutter_texture_new_from_file ("redhand.png", &error);
-+ real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
- if (real_hand == NULL)
- {
- g_error ("image load failed: %s", error->message);
diff --git a/meta/recipes-graphics/clutter/clutter/symconflict.patch b/meta/recipes-graphics/clutter/clutter/symconflict.patch
deleted file mode 100644
index 05f3d27500..0000000000
--- a/meta/recipes-graphics/clutter/clutter/symconflict.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Upstream-Status: Pending
-
-Index: git/tests/test-depth.c
-===================================================================
---- git.orig/tests/test-depth.c 2009-05-24 14:54:40.000000000 +0100
-+++ git/tests/test-depth.c 2009-05-24 14:55:13.000000000 +0100
-@@ -11,13 +11,13 @@
- clutter_timeline_start (timeline);
- }
-
--static ClutterActor *raise[2];
-+static ClutterActor *clutterraise[2];
- static gboolean raise_no = 0;
-
- static gboolean
- raise_top (gpointer ignored)
- {
-- clutter_actor_raise_top (raise[raise_no]);
-+ clutter_actor_raise_top (clutterraise[raise_no]);
- raise_no = !raise_no;
- return TRUE;
- }
-@@ -202,8 +202,8 @@
-
- clutter_timeline_start (timeline);
-
-- raise[0] = rect;
-- raise[1] = hand;
-+ clutterraise[0] = rect;
-+ clutterraise[1] = hand;
- g_timeout_add (2000, raise_top, NULL);
-
- clutter_main ();
diff --git a/meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch b/meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch
deleted file mode 100644
index ccc6c2a32d..0000000000
--- a/meta/recipes-graphics/clutter/clutter/test-conformance-fix.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-Compiling conformance test leads running test-conformance target binary, and
-gets failure in cross-compile environment. Introduce this commit from upstream
-to fix it.
-
-Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
-
-
-commit 7fd6273c25569fe4f37ad371532d93e5170e51f7
-Author: Neil Roberts <neil@linux.intel.com>
-Date: Mon Oct 11 16:16:45 2010 +0100
-
- tests: Generate the stub scripts using sed
-
- Instead of trying to run ./test-conformance with the -l option to
- generate a list of available tests it now runs sed on the
- test-conform-main.c file instead. Running the generated executable is
- a pain for cross-compiling so it would be nice to avoid it unless it's
- absolutely necessary. Although you could tell people who are cross
- compiling to just disable the conformance tests, this seems a shame
- because they could still be useful along with the wrappers for example
- if the cross compile is built to a shared network folder where the
- tests can be run on the actual device.
-
- The sed script is a little more ugly than it could be because it tries
- to avoid using the GNU extensions '\+' and '\|'.
-
- The script ends up placing restrictions on the format of the C file
- because the tests must all be listed on one line each. There is now a
- comment to explain this. Hopefully the trade off is worth it.
-
- http://bugzilla.clutter-project.org/show_bug.cgi?id=2363
-
-Upstream-Status: Backport
-
-diff --git a/tests/conform/Makefile.am b/tests/conform/Makefile.am
-index 3036639..1e723e7 100644
---- a/tests/conform/Makefile.am
-+++ b/tests/conform/Makefile.am
-@@ -89,9 +89,11 @@ test_conformance_SOURCES = $(common_sources) $(units_sources)
-
- wrappers: stamp-test-conformance
- @true
--stamp-test-conformance: Makefile test-conformance$(EXEEXT)
-+stamp-test-conformance: Makefile $(srcdir)/test-conform-main.c
- @mkdir -p wrappers
-- @( $(abs_builddir)/test-conformance$(EXEEXT) -l -m thorough | $(GREP) '^/' ) > unit-tests
-+ @sed -n -e 's/^ \{1,\}TEST_CONFORM_SIMPLE *(.*"\([^",]\{1,\}\)", *\([a-zA-Z0-9_]\{1,\}\).*/\/conform\1\/\2/p' \
-+ -e 's/^ \{1,\}TEST_CONFORM_SKIP *(.*"\([^",]\{1,\}\)", *\([a-zA-Z0-9_]\{1,\}\).*/\/conform\1\/\2/p' \
-+ $(srcdir)/test-conform-main.c > unit-tests
- @chmod +x test-launcher.sh
- @( echo "/stamp-test-conformance" ; \
- echo "/test-conformance" ; \
-diff --git a/tests/conform/test-conform-main.c b/tests/conform/test-conform-main.c
-index a8b3cf8..2ae7a04 100644
---- a/tests/conform/test-conform-main.c
-+++ b/tests/conform/test-conform-main.c
-@@ -92,6 +92,11 @@ main (int argc, char **argv)
- {
- clutter_test_init (&argc, &argv);
-
-+ /* This file is run through a sed script during the make step so the
-+ lines containing the tests need to be formatted on a single line
-+ each. To comment out a test use the SKIP or TODO macros. Using
-+ #if 0 would break the script. */
-+
- TEST_CONFORM_SIMPLE ("/timeline", test_timeline);
- TEST_CONFORM_SKIP (!g_test_slow (), "/timeline", test_timeline_interpolate);
- TEST_CONFORM_SKIP (!g_test_slow (), "/timeline", test_timeline_rewind);
diff --git a/meta/recipes-graphics/clutter/clutter/update_gettext_macro_version.patch b/meta/recipes-graphics/clutter/clutter/update_gettext_macro_version.patch
deleted file mode 100644
index 6671098902..0000000000
--- a/meta/recipes-graphics/clutter/clutter/update_gettext_macro_version.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Upstream-Status: Pending
-
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
-
-Index: clutter-1.6.14/build/autotools/po.m4
-===================================================================
---- clutter-1.6.14.orig/build/autotools/po.m4 2011-05-31 22:39:55.000000000 -0700
-+++ clutter-1.6.14/build/autotools/po.m4 2011-05-31 22:40:36.898833113 -0700
-@@ -29,7 +29,7 @@
-
- dnl Release version of the gettext macros. This is used to ensure that
- dnl the gettext macros and po/Makefile.in.in are in sync.
-- AC_SUBST([GETTEXT_MACRO_VERSION], [0.17])
-+ AC_SUBST([GETTEXT_MACRO_VERSION], [0.18])
-
- dnl Perform the following tests also if --disable-nls has been given,
- dnl because they are needed for "make dist" to work.
-Index: clutter-1.6.14/po/Makefile.in.in
-===================================================================
---- clutter-1.6.14.orig/po/Makefile.in.in 2011-05-31 22:40:05.000000000 -0700
-+++ clutter-1.6.14/po/Makefile.in.in 2011-05-31 22:40:21.030833109 -0700
-@@ -8,8 +8,8 @@
- # Please note that the actual code of GNU gettext is covered by the GNU
- # General Public License and is *not* in the public domain.
- #
--# Origin: gettext-0.17
--GETTEXT_MACRO_VERSION = 0.17
-+# Origin: gettext-0.18
-+GETTEXT_MACRO_VERSION = 0.18
-
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@