aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.32.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb b/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
index ff17cf75ed..dcacce4b00 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
@@ -55,3 +55,14 @@ FILES_librsvg-gtk-dbg += "${libdir}/gdk-pixbuf-2.0/.debug \
PIXBUF_PACKAGES = "librsvg-gtk"
PARALLEL_MAKE = ""
+
+# ensure that the native gdk-pixbuf loaders cache is updated when we stage
+# our svg loader
+SSTATEPOSTINSTFUNCS_class_native += "librsvg_sstate_postinst"
+
+librsvg_sstate_postinst() {
+ if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
+ then
+ GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders.cache gdk-pixbuf-query-loaders --update-cache
+ fi
+}