aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsb')
-rw-r--r--meta/recipes-extended/lsb/lsb_1.4.bb62
1 files changed, 31 insertions, 31 deletions
diff --git a/meta/recipes-extended/lsb/lsb_1.4.bb b/meta/recipes-extended/lsb/lsb_1.4.bb
index 15dbeaafdf..513998cab8 100644
--- a/meta/recipes-extended/lsb/lsb_1.4.bb
+++ b/meta/recipes-extended/lsb/lsb_1.4.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "LSB support for OpenEmbedded"
SECTION = "console/utils"
HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
LICENSE = "GPLv2+"
-PR = "r3"
+PR = "r4"
# lsb_release needs getopt
RDEPENDS_${PN} += "util-linux"
@@ -23,54 +23,54 @@ S = "${WORKDIR}/lsb-release-${PV}"
do_install(){
oe_runmake install prefix=${D} mandir=${D}/${datadir}/man/ DESTDIR=${D}
- mkdir -p ${D}/bin
+ mkdir -p ${D}${base_bindir}
mkdir -p ${D}/${baselib}
- mkdir -p ${D}/etc/lsb-release.d
- echo -n "LSB_VERSION=\"core-4.1-noarch:" > ${D}/etc/lsb-release
+ mkdir -p ${D}${sysconfdir}/lsb-release.d
+ echo -n "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
if [ "${TARGET_ARCH}" = "i586" ];then
- echo -n "core-4.1-ia32" >> ${D}/etc/lsb-release
+ echo -n "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release
else
- echo -n "core-4.1-${TARGET_ARCH}" >> ${D}/etc/lsb-release
+ echo -n "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
fi
- echo "\"" >> ${D}/etc/lsb-release
- echo "DISTRIB_ID=${DISTRO}" >> ${D}/etc/lsb-release
- echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}/etc/lsb-release
- echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}/etc/lsb-release
+ echo "\"" >> ${D}${sysconfdir}/lsb-release
+ echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release
+ echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}${sysconfdir}/lsb-release
+ echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release
if [ "${TARGET_ARCH}" = "i586" ];then
- mkdir -p ${D}/etc/lsb-release.d
- touch ${D}/etc/lsb-release.d/graphics-4.1-noarch
- touch ${D}/etc/lsb-release.d/graphics-${PV}-noarch
- touch ${D}/etc/lsb-release.d/desktop-${PV}-noarch
- touch ${D}/etc/lsb-release.d/graphics-4.1-ia32
- touch ${D}/etc/lsb-release.d/graphics-${PV}-ia32
- touch ${D}/etc/lsb-release.d/desktop-${PV}-ia32
+ mkdir -p ${D}${sysconfdir}/lsb-release.d
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
+ touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-noarch
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-ia32
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ia32
+ touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ia32
elif [ "${TARGET_ARCH}" = "x86_64" ];then
- touch ${D}/etc/lsb-release.d/graphics-4.1-noarch
- touch ${D}/etc/lsb-release.d/graphics-4.1-amd64
- touch ${D}/etc/lsb-release.d/graphics-${PV}-amd64
- touch ${D}/etc/lsb-release.d/desktop-${PV}-amd64
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-amd64
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-amd64
+ touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-amd64
fi
if [ "${TARGET_ARCH}" = "powerpc" ];then
- touch ${D}/etc/lsb-release.d/graphics-4.1-noarch
- touch ${D}/etc/lsb-release.d/graphics-4.1-ppc32
- touch ${D}/etc/lsb-release.d/graphics-${PV}-ppc32
- touch ${D}/etc/lsb-release.d/desktop-${PV}-ppc32
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-ppc32
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc32
+ touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc32
elif [ "${TARGET_ARCH}" = "powerpc64" ];then
- touch ${D}/etc/lsb-release.d/graphics-4.1-noarch
- touch ${D}/etc/lsb-release.d/graphics-4.1-ppc64
- touch ${D}/etc/lsb-release.d/graphics-${PV}-ppc64
- touch ${D}/etc/lsb-release.d/desktop-${PV}-ppc64
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-ppc64
+ touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc64
+ touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc64
fi
}
do_install_append(){
- install -d ${D}/etc/core-lsb
+ install -d ${D}${sysconfdir}/core-lsb
install -d ${D}/${baselib}/lsb
for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon
do
- install -m 0755 ${WORKDIR}/${i} ${D}/etc/core-lsb
+ install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb
done
install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb
if [ "${TARGET_ARCH}" = "x86_64" ];then
on> OpenEmbedded Core user contribution treesGrokmirror user
aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.07.bb
blob: 76a3fd8ae40232391059cc6f04e1ecf50882d509 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
SUMMARY = "Linux man-pages"
DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
SECTION = "console/utils"
HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
LICENSE = "GPLv2+"

LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"

SRC_URI[md5sum] = "05ba1cb21e99d02bd7bc1a59378965d2"
SRC_URI[sha256sum] = "c973351131931f7700f5e9fbf4ef366c43ea7c1515d282e8d5db9c77590c4c93"

RDEPENDS_${PN} = "man"

do_configure[noexec] = "1"
do_compile[noexec] = "1"

do_install() {
        oe_runmake install DESTDIR=${D}
}

# Only deliveres man-pages so FILES_${PN} gets everything
FILES_${PN}-doc = ""
FILES_${PN} = "${mandir}/*"

inherit update-alternatives

ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"