aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-async_0.6.2.bb2
-rw-r--r--meta/recipes-devtools/python/python3-git_2.1.5.bb2
-rw-r--r--meta/recipes-devtools/python/python3-gitdb_0.6.4.bb2
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb1
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.24.1.bb2
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.2.7.bb3
-rw-r--r--meta/recipes-devtools/python/python3-smmap_0.9.0.bb2
7 files changed, 5 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python3-async_0.6.2.bb b/meta/recipes-devtools/python/python3-async_0.6.2.bb
index 54a30f5498..f45781c44f 100644
--- a/meta/recipes-devtools/python/python3-async_0.6.2.bb
+++ b/meta/recipes-devtools/python/python3-async_0.6.2.bb
@@ -2,5 +2,5 @@ require python-async.inc
inherit setuptools3
-RDEPENDS_${PN} += "python3-threading python3-lang"
+RDEPENDS_${PN} += "python3-threading"
diff --git a/meta/recipes-devtools/python/python3-git_2.1.5.bb b/meta/recipes-devtools/python/python3-git_2.1.5.bb
index 4ac2a0ec79..ca42688f97 100644
--- a/meta/recipes-devtools/python/python3-git_2.1.5.bb
+++ b/meta/recipes-devtools/python/python3-git_2.1.5.bb
@@ -4,4 +4,4 @@ DEPENDS = "python3-gitdb"
inherit setuptools3
-RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient python3-unittest python3-argparse git"
+RDEPENDS_${PN} += "python3-gitdb python3-io python3-shell python3-math python3-stringold python3-unixadmin python3-logging python3-datetime python3-netclient python3-unittest git"
diff --git a/meta/recipes-devtools/python/python3-gitdb_0.6.4.bb b/meta/recipes-devtools/python/python3-gitdb_0.6.4.bb
index 80d9d469af..a209c52f9e 100644
--- a/meta/recipes-devtools/python/python3-gitdb_0.6.4.bb
+++ b/meta/recipes-devtools/python/python3-gitdb_0.6.4.bb
@@ -4,4 +4,4 @@ DEPENDS = "python3-async python3-smmap"
inherit distutils3
-RDEPENDS_${PN} += "python3-smmap python3-async python3-mmap python3-lang python3-io python3-shell python3-crypt python3-compression"
+RDEPENDS_${PN} += "python3-smmap python3-async python3-mmap python3-io python3-shell python3-crypt python3-compression"
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index 9b907a2631..a6dd72df3b 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -44,7 +44,6 @@ do_install_append() {
RDEPENDS_${PN} = "\
python3-compile \
python3-io \
- python3-enum \
python3-html \
python3-json \
python3-netserver \
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
index 9d10af2e08..f4efb14bd2 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
@@ -26,7 +26,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wa
# we don't link against python3-pycairo -> RDEPENDS
PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
-RDEPENDS_${PN} += "python3-setuptools python3-importlib"
+RDEPENDS_${PN} += "python3-setuptools"
BBCLASSEXTEND = "native"
PACKAGECONFIG_class-native = ""
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
index 63f241809e..dab8ad89b0 100644
--- a/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
@@ -23,12 +23,9 @@ RDEPENDS_${PN} = "\
python3-ctypes \
python3-distutils \
python3-email \
- python3-importlib \
python3-numbers \
python3-compression \
python3-shell \
- python3-subprocess \
- python3-textutils \
python3-pkgutil \
python3-threading \
python3-misc \
diff --git a/meta/recipes-devtools/python/python3-smmap_0.9.0.bb b/meta/recipes-devtools/python/python3-smmap_0.9.0.bb
index 9f8a26d79e..1df74c172c 100644
--- a/meta/recipes-devtools/python/python3-smmap_0.9.0.bb
+++ b/meta/recipes-devtools/python/python3-smmap_0.9.0.bb
@@ -2,4 +2,4 @@ require python-smmap.inc
inherit setuptools3
-RDEPENDS_${PN} += "python3-codecs python3-mmap python3-lang"
+RDEPENDS_${PN} += "python3-codecs python3-mmap"