summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.07.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.07.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.07.bb b/meta/recipes-devtools/nasm/nasm_2.10.07.bb
new file mode 100644
index 0000000000..1c95ed82bc
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.07.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
+
+PR = "r0"
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
+SRC_URI[md5sum] = "af1cd6669f5e98148cd5ec42dee90f19"
+SRC_URI[sha256sum] = "c056e2abc83816892e448f9e9e95a3d21e9e096f44341b9d4853f62a443bba82"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
+ mv aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"