summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dnf')
-rw-r--r--meta/recipes-devtools/dnf/dnf_4.2.2.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.2.2.bb b/meta/recipes-devtools/dnf/dnf_4.2.2.bb
index 3970b41121..c77773332c 100644
--- a/meta/recipes-devtools/dnf/dnf_4.2.2.bb
+++ b/meta/recipes-devtools/dnf/dnf_4.2.2.bb
@@ -26,7 +26,7 @@ EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -
BBCLASSEXTEND = "native nativesdk"
-RDEPENDS_${PN}_class-target += " \
+RDEPENDS_${PN} += " \
python3-core \
python3-codecs \
python3-netclient \
@@ -49,6 +49,8 @@ RDEPENDS_${PN}_class-target += " \
python3-gpg \
"
+RDEPENDS_${PN}_class-native = ""
+
RRECOMMENDS_${PN}_class-target += "gnupg"
# Create a symlink called 'dnf' as 'make install' does not do it, but
@@ -66,6 +68,12 @@ do_install_append_class-native() {
RPM_NO_CHROOT_FOR_SCRIPTS=1
}
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/dnf \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
+ RPM_NO_CHROOT_FOR_SCRIPTS=1
+}
+
SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
dnf-automatic.service dnf-automatic.timer \
dnf-automatic-download.service dnf-automatic-download.timer \