aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_206.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-core/systemd/systemd_206.bb b/meta/recipes-core/systemd/systemd_206.bb
index 8d0a0657bb..02be7935cd 100644
--- a/meta/recipes-core/systemd/systemd_206.bb
+++ b/meta/recipes-core/systemd/systemd_206.bb
@@ -117,14 +117,13 @@ do_install() {
do_install_ptest () {
install -d ${D}${PTEST_PATH}/test
- install -d ${D}${libdir}/udev/rules.d
- install ${B}/test/* ${D}${PTEST_PATH}/test
+ install ${S}/test/* ${D}${PTEST_PATH}/test
install -m 0755 ${B}/test-udev ${D}${PTEST_PATH}/
install -d ${D}${PTEST_PATH}/build-aux
cp -rf ${B}/rules ${D}${PTEST_PATH}/
cp ${B}/Makefile ${D}${PTEST_PATH}/
- cp ${B}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
- tar -C ${D}${PTEST_PATH}/test -xJf ${B}/test/sys.tar.xz
+ cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
+ tar -C ${D}${PTEST_PATH}/test -xJf ${S}/test/sys.tar.xz
sed -i 's/"tree"/"ls"/' ${D}${PTEST_PATH}/test/udev-test.pl
}