summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ell/ell_0.33.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.33.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.33.bb b/meta/recipes-core/ell/ell_0.33.bb
new file mode 100644
index 0000000000..bef1e9a0b5
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.33.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Embedded Linux Library"
+HOMEPAGE = "https://01.org/ell"
+DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
+low-level functionality for system daemons. It typically has no \
+dependencies other than the Linux kernel, C standard library, and \
+libdl (for dynamic linking). While ELL is designed to be efficient \
+and compact enough for use on embedded Linux platforms, it is not \
+limited to resource-constrained systems."
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
+
+DEPENDS = "dbus"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
+SRC_URI[sha256sum] = "d9e40e641164150394b74b719b9726fc734f24b2cde679cf5f3be6915c34eded"
+
+do_configure_prepend () {
+ mkdir -p ${S}/build-aux
+}