aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb11
-rwxr-xr-xmeta/recipes-bsp/qemu-config/qemu-config/qemu-autostart37
2 files changed, 2 insertions, 46 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index 6775af34e3..4179fc0492 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -11,8 +11,7 @@ PR = "r25"
SRC_URI = "file://distcc.sh \
file://exports \
- file://shutdown.desktop \
- file://qemu-autostart"
+ file://shutdown.desktop"
S = "${WORKDIR}"
@@ -24,9 +23,6 @@ do_install() {
install -d ${D}${datadir}/applications
install -m 0644 shutdown.desktop ${D}${datadir}/applications/
-
- install -d ${D}${sysconfdir}/init.d
- install qemu-autostart ${D}${sysconfdir}/init.d/
}
pkg_postinst_${PN} () {
@@ -36,7 +32,4 @@ pkg_postinst_${PN} () {
RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
-inherit update-rc.d allarch
-
-INITSCRIPT_NAME = "qemu-autostart"
-INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."
+inherit allarch
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/qemu-autostart b/meta/recipes-bsp/qemu-config/qemu-config/qemu-autostart
deleted file mode 100755
index db2668eb4e..0000000000
--- a/meta/recipes-bsp/qemu-config/qemu-config/qemu-autostart
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: hddtemp
-# Required-Start: $network
-# Required-Stop: $network
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: OProfile server
-# Description:
-### END INIT INFO
-
-. /etc/init.d/functions
-
-case "$1" in
- start)
- echo "Starting automatic qemu services"
- . /etc/profile
- /usr/bin/oprofile-server &
- ;;
-
- stop)
- echo "Stopping qemu services"
- killproc oprofile-server
- ;;
-
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
-
- *)
- echo "usage: $0 { start | stop | restart }"
- ;;
-esac
-
-exit 0