aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
index 0108e0059f..a1b1db9555 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
@@ -1,17 +1,18 @@
DESCRIPTION = "U-boot bootloader mkimage tool"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
- file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
SECTION = "bootloader"
-SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+# This revision corresponds to the tag "v2013.07"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
-SRC_URI[md5sum] = "8445162690052e6afd4b8f87af2bb557"
-SRC_URI[sha256sum] = "2bbd440c1b29928d230604eac372fda5152d3ae23f52b1910c77fc5bf531250b"
+PV = "v2013.07+git${SRCPV}"
-S = "${WORKDIR}/u-boot-${PV}"
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
-BBCLASSEXTEND = "native nativesdk"
+S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
@@ -25,3 +26,4 @@ do_install () {
ln -sf uboot-mkimage ${D}${bindir}/mkimage
}
+BBCLASSEXTEND = "native nativesdk"