aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/quilt/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/quilt/files')
-rw-r--r--meta/packages/quilt/files/install.patch19
-rw-r--r--meta/packages/quilt/files/non-gnu.patch13
-rw-r--r--meta/packages/quilt/files/nostrip.patch16
3 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/quilt/files/install.patch b/meta/packages/quilt/files/install.patch
new file mode 100644
index 0000000000..4122370d6a
--- /dev/null
+++ b/meta/packages/quilt/files/install.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- quilt-0.32/Makefile.in~install
++++ quilt-0.32/Makefile.in
+@@ -9,9 +9,9 @@
+ libdir := @libdir@
+ datadir := @datadir@
+ docdir := @docdir@
+-mandir := $(datadir)/man
++mandir := @mandir@
+ localedir := $(datadir)/locale
+-etcdir := $(subst /usr/etc,/etc,$(prefix)/etc)
++etcdir := @sysconfdir@
+
+ QUILT_DIR = $(datadir)/$(PACKAGE)
+ SCRIPTS_DIR = $(QUILT_DIR)/scripts
diff --git a/meta/packages/quilt/files/non-gnu.patch b/meta/packages/quilt/files/non-gnu.patch
new file mode 100644
index 0000000000..8b07bc2923
--- /dev/null
+++ b/meta/packages/quilt/files/non-gnu.patch
@@ -0,0 +1,13 @@
+Index: quilt/Makefile.in
+===================================================================
+--- quilt.orig/Makefile.in
++++ quilt/Makefile.in
+@@ -216,7 +216,7 @@
+ -e 's:@LOCALEDIR''@:$(localedir):g' \
+ -e 's:@DOCSUBDIR''@:$(docdir)/$(PACKAGE)-$(VERSION):g' \
+ $< > $@
+- @chmod --reference=$< $@
++ @chmod `stat -f "%p" $<` $@
+
+ Makefile : Makefile.in
+ @echo "Please run ./configure by hand"
diff --git a/meta/packages/quilt/files/nostrip.patch b/meta/packages/quilt/files/nostrip.patch
new file mode 100644
index 0000000000..4dedad96d4
--- /dev/null
+++ b/meta/packages/quilt/files/nostrip.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- quilt-0.32/Makefile.in~nostrip
++++ quilt-0.32/Makefile.in
+@@ -240,7 +240,7 @@
+ @INSTALL@ -m 644 scripts/patchfns $(BUILD_ROOT)$(SCRIPTS_DIR)
+
+ @INSTALL@ -d $(BUILD_ROOT)$(LIB_DIR)
+- @INSTALL@ -m 755 -s $(LIB:%=lib/%) $(BUILD_ROOT)$(LIB_DIR)/
++ @INSTALL@ -m 755 $(LIB:%=lib/%) $(BUILD_ROOT)$(LIB_DIR)/
+
+ @INSTALL@ -d $(BUILD_ROOT)$(docdir)/$(PACKAGE)-$(VERSION)/
+ @INSTALL@ -m 644 doc/README \