aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-panel
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-panel')
-rw-r--r--meta/packages/matchbox-panel/matchbox-panel.inc22
-rw-r--r--meta/packages/matchbox-panel/matchbox-panel_0.9.2.bb6
-rw-r--r--meta/packages/matchbox-panel/matchbox-panel_svn.bb11
3 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/matchbox-panel/matchbox-panel.inc b/meta/packages/matchbox-panel/matchbox-panel.inc
new file mode 100644
index 0000000000..d5d3551619
--- /dev/null
+++ b/meta/packages/matchbox-panel/matchbox-panel.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "Matchbox Window Manager Panel"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox libx11 libxext libxpm apmd startup-notification virtual/kernel wireless-tools"
+SECTION = "x11/wm"
+
+inherit autotools pkgconfig gettext
+
+CFLAGS += "-D_GNU_SOURCE"
+
+EXTRA_OECONF = " --enable-startup-notification --enable-dnotify "
+EXTRA_OECONF_append_h3600 = " --enable-small-icons "
+EXTRA_OECONF_append_h3900 = " --enable-small-icons "
+EXTRA_OECONF_append_h2200 = " --enable-small-icons "
+EXTRA_OECONF_append_collie = " --enable-small-icons "
+EXTRA_OECONF_append_poodle = " --enable-small-icons "
+EXTRA_OECONF_append_mnci = " --enable-small-icons "
+EXTRA_OECONF_append_integral13 = " --enable-small-icons "
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/applications \
+ ${datadir}/pixmaps"
+
diff --git a/meta/packages/matchbox-panel/matchbox-panel_0.9.2.bb b/meta/packages/matchbox-panel/matchbox-panel_0.9.2.bb
new file mode 100644
index 0000000000..78d1b282d9
--- /dev/null
+++ b/meta/packages/matchbox-panel/matchbox-panel_0.9.2.bb
@@ -0,0 +1,6 @@
+include matchbox-panel.inc
+
+PR="r3"
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz"
+
+
diff --git a/meta/packages/matchbox-panel/matchbox-panel_svn.bb b/meta/packages/matchbox-panel/matchbox-panel_svn.bb
new file mode 100644
index 0000000000..211cf3caa2
--- /dev/null
+++ b/meta/packages/matchbox-panel/matchbox-panel_svn.bb
@@ -0,0 +1,11 @@
+include matchbox-panel.inc
+PV = "0.9.2+svn${SRCDATE}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+
+EXTRA_OECONF = "--enable-startup-notification --enable-dnotify"
+
+S = ${WORKDIR}/${PN}
+
+