aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/gnome/gconf-dbus
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gnome/gconf-dbus')
-rwxr-xr-xmeta/packages/gnome/gconf-dbus/69gconfd-dbus3
-rwxr-xr-xmeta/packages/gnome/gconf-dbus/gconf-dbus-update.patch31
-rw-r--r--meta/packages/gnome/gconf-dbus/no-deprecation.patch11
-rw-r--r--meta/packages/gnome/gconf-dbus/remove-old-translations.patch11
-rw-r--r--meta/packages/gnome/gconf-dbus/xml-backend-locks-compile-fix.patch16
-rw-r--r--meta/packages/gnome/gconf-dbus/xml-backend-oldxml-Makefile.patch11
6 files changed, 83 insertions, 0 deletions
diff --git a/meta/packages/gnome/gconf-dbus/69gconfd-dbus b/meta/packages/gnome/gconf-dbus/69gconfd-dbus
new file mode 100755
index 0000000000..c2add042f6
--- /dev/null
+++ b/meta/packages/gnome/gconf-dbus/69gconfd-dbus
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/libexec/gconfd-2 &
diff --git a/meta/packages/gnome/gconf-dbus/gconf-dbus-update.patch b/meta/packages/gnome/gconf-dbus/gconf-dbus-update.patch
new file mode 100755
index 0000000000..9870078b86
--- /dev/null
+++ b/meta/packages/gnome/gconf-dbus/gconf-dbus-update.patch
@@ -0,0 +1,31 @@
+? gconf/gconf.service
+Index: gconf/Makefile.am
+===================================================================
+RCS file: /cvs/gnome/gconf/gconf/Makefile.am,v
+retrieving revision 1.78.4.8
+diff -u -r1.78.4.8 Makefile.am
+--- gconf/Makefile.am 21 Dec 2003 14:21:15 -0000 1.78.4.8
++++ gconf/Makefile.am 22 Jan 2005 00:30:13 -0000
+@@ -155,6 +155,7 @@
+
+ libgconf_2_la_LDFLAGS = -version-info $(GCONF_CURRENT):$(GCONF_REVISION):$(GCONF_AGE) -no-undefined
+ libgconf_2_la_LIBADD = $(INTLLIBS) $(DEPENDENT_LIBS) $(GCONF_IPC_LIBS)
++libgconf_2_la_CFLAGS = $(AM_CFLAGS)
+
+ if HAVE_DBUS
+ servicedir = $(DBUS_SERVICE_DIR)
+Index: backends/Makefile.am
+===================================================================
+RCS file: /cvs/gnome/gconf/backends/Makefile.am,v
+retrieving revision 1.30
+diff -u -r1.30 Makefile.am
+--- backends/Makefile.am 3 Nov 2003 00:19:33 -0000 1.30
++++ backends/Makefile.am 22 Jan 2005 00:30:14 -0000
+@@ -17,6 +17,7 @@
+
+ libgconfbackend_oldxml_la_LDFLAGS = -avoid-version -module -no-undefined
+ libgconfbackend_oldxml_la_LIBADD = $(DEPENDENT_WITH_XML_LIBS) $(top_builddir)/gconf/libgconf-$(MAJOR_VERSION).la
++libgconfbackend_oldxml_la_CFLAGS = $(AM_CFLAGS)
+
+ libgconfbackend_xml_la_SOURCES = \
+ markup-backend.c \
diff --git a/meta/packages/gnome/gconf-dbus/no-deprecation.patch b/meta/packages/gnome/gconf-dbus/no-deprecation.patch
new file mode 100644
index 0000000000..133ea550ee
--- /dev/null
+++ b/meta/packages/gnome/gconf-dbus/no-deprecation.patch
@@ -0,0 +1,11 @@
+--- trunk/examples/basic-gconf-app.c.old 2006-04-25 20:39:48.000000000 +0100
++++ trunk/examples/basic-gconf-app.c 2006-04-25 20:40:11.000000000 +0100
+@@ -80,7 +80,7 @@
+
+ /* Be clean and pure */
+ #define GTK_DISABLE_DEPRECATED
+-#define G_DISABLE_DEPRECATED
++/*#define G_DISABLE_DEPRECATED*/
+
+ #include <gconf/gconf-client.h>
+ #include <gtk/gtk.h>
diff --git a/meta/packages/gnome/gconf-dbus/remove-old-translations.patch b/meta/packages/gnome/gconf-dbus/remove-old-translations.patch
new file mode 100644
index 0000000000..486570040f
--- /dev/null
+++ b/meta/packages/gnome/gconf-dbus/remove-old-translations.patch
@@ -0,0 +1,11 @@
+--- trunk/configure.in.old 2006-06-21 13:49:59.000000000 +0100
++++ trunk/configure.in 2006-06-21 13:50:21.000000000 +0100
+@@ -189,7 +189,7 @@
+
+ AC_CHECK_FUNCS(flockfile)
+
+-ALL_LINGUAS="am ar az be bg bn ca cs cy da de el en_GB es eu fa fi fr ga gl hi hr hu id it ja ko lt lv mk ml mn ms nl nn no pl pt pt_BR ro ru sk sl sq sr sr@Latn sv tr uk vi yi zh_CN zh_TW ta"
++ALL_LINGUAS="am ar az be bg bn ca cs cy da de el en_GB es eu fa fi fr ga gl hi hr hu id it ja ko lt lv mk ml ms nl nn no pl pt pt_BR ro ru sk sl sq sr sr@Latn sv tr uk vi yi zh_CN zh_TW ta"
+
+ AM_GLIB_GNU_GETTEXT
+
diff --git a/meta/packages/gnome/gconf-dbus/xml-backend-locks-compile-fix.patch b/meta/packages/gnome/gconf-dbus/xml-backend-locks-compile-fix.patch
new file mode 100644
index 0000000000..c195aad639
--- /dev/null
+++ b/meta/packages/gnome/gconf-dbus/xml-backend-locks-compile-fix.patch
@@ -0,0 +1,16 @@
+--- trunk/backends/xml-backend.c~ 2006-01-18 09:57:39.000000000 -0800
++++ trunk/backends/xml-backend.c 2006-01-19 11:38:37.000000000 -0800
+@@ -115,6 +115,13 @@
+
+ typedef struct _XMLSource XMLSource;
+
++extern GConfLock*
++gconf_get_lock (const gchar *lock_directory,
++ GError **err);
++extern gboolean
++gconf_release_lock (GConfLock *lock,
++ GError **err);
++
+ /* XMLSource **/
+
+ struct _XMLSource {
diff --git a/meta/packages/gnome/gconf-dbus/xml-backend-oldxml-Makefile.patch b/meta/packages/gnome/gconf-dbus/xml-backend-oldxml-Makefile.patch
new file mode 100644
index 0000000000..312a356c84
--- /dev/null
+++ b/meta/packages/gnome/gconf-dbus/xml-backend-oldxml-Makefile.patch
@@ -0,0 +1,11 @@
+--- trunk/backends/Makefile~ 2006-01-19 09:52:22.000000000 -0800
++++ trunk/backends/Makefile 2006-01-19 13:13:23.000000000 -0800
+@@ -84,7 +84,7 @@
+ xml_test_OBJECTS = $(am_xml_test_OBJECTS)
+ xml_test_DEPENDENCIES = $(am__DEPENDENCIES_1) \
+ $(top_builddir)/gconf/libgconf-$(MAJOR_VERSION).la \
+- $(top_builddir)/backends/libgconfbackend-oldxml.la
++ libgconfbackend-oldxml.la
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles