aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/gettext
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gettext')
-rw-r--r--meta/packages/gettext/gettext-0.14.1/fixchicken.patch26
-rw-r--r--meta/packages/gettext/gettext-0.14.1/gettext-vpath.patch11
-rw-r--r--meta/packages/gettext/gettext-native_0.14.1.bb53
-rw-r--r--meta/packages/gettext/gettext_0.14.1.bb33
4 files changed, 123 insertions, 0 deletions
diff --git a/meta/packages/gettext/gettext-0.14.1/fixchicken.patch b/meta/packages/gettext/gettext-0.14.1/fixchicken.patch
new file mode 100644
index 0000000000..4174f6d747
--- /dev/null
+++ b/meta/packages/gettext/gettext-0.14.1/fixchicken.patch
@@ -0,0 +1,26 @@
+Index: gettext-tools/m4/csharpcomp.m4
+===================================================================
+RCS file: /cvs/gettext/gettext/gettext-tools/m4/csharpcomp.m4,v
+retrieving revision 1.4
+retrieving revision 1.6
+diff -u -r1.4 -r1.6
+--- a/gettext-tools/m4/csharpcomp.m4 30 Jan 2004 11:01:18 -0000 1.4
++++ a/gettext-tools/m4/csharpcomp.m4 26 May 2004 12:15:23 -0000 1.6
+@@ -1,4 +1,4 @@
+-# csharpcomp.m4 serial 2 (gettext-0.14.1)
++# csharpcomp.m4 serial 4 (gettext-0.15)
+ dnl Copyright (C) 2003-2004 Free Software Foundation, Inc.
+ dnl This file is free software, distributed under the terms of the GNU
+ dnl General Public License. As a special exception to the GNU General
+@@ -43,7 +43,8 @@
+ ;;
+ sscli)
+ if test -n "$HAVE_CSC_IN_PATH" \
+- && csc -help >/dev/null 2>/dev/null; then
++ && csc -help >/dev/null 2>/dev/null \
++ && { if csc -help 2>/dev/null | grep -i chicken > /dev/null; then false; else true; fi; }; then
+ HAVE_CSC=1
+ ac_result="csc"
+ break
+
+
diff --git a/meta/packages/gettext/gettext-0.14.1/gettext-vpath.patch b/meta/packages/gettext/gettext-0.14.1/gettext-vpath.patch
new file mode 100644
index 0000000000..8251ac0e73
--- /dev/null
+++ b/meta/packages/gettext/gettext-0.14.1/gettext-vpath.patch
@@ -0,0 +1,11 @@
+--- gettext-0.14.1/gettext-runtime/intl/Makefile.in~ 2004-04-09 13:23:40.000000000 +0100
++++ gettext-0.14.1/gettext-runtime/intl/Makefile.in 2004-04-09 13:22:05.000000000 +0100
+@@ -24,7 +24,7 @@
+ srcdir = $(top_srcdir)/../gettext-runtime/intl
+ top_srcdir = /var/tmp/oe-tmp.pb/base/gettext-0.14.1-r0/gettext-0.14.1/gettext-tools
+ top_builddir = ..
+-VPATH = $(srcdir)
++#VPATH = $(srcdir)
+
+ prefix = /usr
+ exec_prefix = /usr
diff --git a/meta/packages/gettext/gettext-native_0.14.1.bb b/meta/packages/gettext/gettext-native_0.14.1.bb
new file mode 100644
index 0000000000..07c9361a19
--- /dev/null
+++ b/meta/packages/gettext/gettext-native_0.14.1.bb
@@ -0,0 +1,53 @@
+include gettext_${PV}.bb
+S = "${WORKDIR}/gettext-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gettext-${PV}"
+inherit native
+PROVIDES = ""
+
+M4 = "\
+lib-ld.m4 \
+lib-link.m4 \
+lib-prefix.m4 \
+codeset.m4 \
+gettext.m4 \
+glibc21.m4 \
+iconv.m4 \
+intdiv0.m4 \
+intmax.m4 \
+inttypes.m4 \
+inttypes_h.m4 \
+inttypes-pri.m4 \
+isc-posix.m4 \
+lcmessage.m4 \
+longdouble.m4 \
+longlong.m4 \
+nls.m4 \
+po.m4 \
+printf-posix.m4 \
+progtest.m4 \
+signed.m4 \
+size_max.m4 \
+stdint_h.m4 \
+uintmax_t.m4 \
+ulonglong.m4 \
+wchar_t.m4 \
+wint_t.m4 \
+xsize.m4 \
+"
+
+do_stage_append() {
+ for i in ${M4}; do
+ src="gettext-runtime/m4/$i"
+ if [ ! -f $src ]; then
+ src="gettext-tools/m4/$i"
+ fi
+ if [ ! -f $src ]; then
+ src="autoconf-lib-link/m4/$i"
+ fi
+ if [ ! -f $src ]; then
+ echo "can't find $i" >&2
+ exit 1
+ fi
+ install -m 0644 $src ${STAGING_DATADIR}/aclocal/$i
+ done
+}
diff --git a/meta/packages/gettext/gettext_0.14.1.bb b/meta/packages/gettext/gettext_0.14.1.bb
new file mode 100644
index 0000000000..9e2222aa0e
--- /dev/null
+++ b/meta/packages/gettext/gettext_0.14.1.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The GNU internationalization library."
+HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r3"
+PROVIDES = "virtual/libintl"
+
+SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
+ file://gettext-vpath.patch;patch=1;pnum=1 \
+ file://fixchicken.patch;patch=1;pnum=1"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF += "--without-lisp"
+acpaths = '-I ${S}/autoconf-lib-link/m4/ \
+ -I ${S}/gettext-runtime/m4 \
+ -I ${S}/gettext-tools/m4'
+
+do_configure_prepend() {
+ rm -f ${S}/config/m4/libtool.m4
+ install -m 0644 ${STAGING_DATADIR}/aclocal/libtool.m4 ${S}/config/m4/
+}
+
+do_stage () {
+ autotools_stage_includes
+ oe_libinstall -so -C gettext-tools/lib libgettextlib ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-tools/src libgettextpo ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-tools/src libgettextsrc ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-tools/intl libintl ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-runtime/lib libasprintf ${STAGING_LIBDIR}/
+}