aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/fakeroot
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/fakeroot')
-rw-r--r--meta/packages/fakeroot/fakeroot-native_1.2.13.bb19
-rw-r--r--meta/packages/fakeroot/fakeroot_1.2.13.bb8
-rw-r--r--meta/packages/fakeroot/files/fix-prefix.patch18
3 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot-native_1.2.13.bb b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
new file mode 100644
index 0000000000..cc3dfd2231
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
@@ -0,0 +1,19 @@
+SECTION = "base"
+PR = "r0"
+include fakeroot_${PV}.bb
+inherit native
+
+SRC_URI += "file://fix-prefix.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
diff --git a/meta/packages/fakeroot/fakeroot_1.2.13.bb b/meta/packages/fakeroot/fakeroot_1.2.13.bb
new file mode 100644
index 0000000000..8ae7ca38be
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot_1.2.13.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Gives a fake root environment"
+SECTION = "base"
+HOMEPAGE = "http://joostje.op.het.net/fakeroot/index.html"
+LICENSE = "GPL"
+
+SRC_URI = "http://openzaurus.org/mirror/fakeroot_${PV}.tar.gz"
+
+inherit autotools
diff --git a/meta/packages/fakeroot/files/fix-prefix.patch b/meta/packages/fakeroot/files/fix-prefix.patch
new file mode 100644
index 0000000000..3884aca01c
--- /dev/null
+++ b/meta/packages/fakeroot/files/fix-prefix.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- fakeroot-1.2.13/scripts/fakeroot.in~fix-prefix
++++ fakeroot-1.2.13/scripts/fakeroot.in
+@@ -15,8 +15,8 @@
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-PREFIX=@prefix@
+-BINDIR=@bindir@
++BINDIR=`dirname $0`
++PREFIX=`dirname ${BINDIR}`
+
+ LIB=lib@fakeroot_transformed@.so.0
+ PATHS=@libdir@:${PREFIX}/lib64/libfakeroot:${PREFIX}/lib32/libfakeroot