aboutsummaryrefslogtreecommitdiffstats
path: root/meta/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta/conf/layer.conf')
-rw-r--r--meta/conf/layer.conf10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
index ed50f1c509..78ceae9db6 100644
--- a/meta/conf/layer.conf
+++ b/meta/conf/layer.conf
@@ -3,9 +3,13 @@ BBPATH .= ":${LAYERDIR}"
# We have a packages directory, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
-BBFILE_COLLECTIONS += "normal"
-BBFILE_PATTERN_normal := "^${LAYERDIR}/"
-BBFILE_PRIORITY_normal = "5"
+BBFILE_COLLECTIONS += "core"
+BBFILE_PATTERN_core := "^${LAYERDIR}/"
+BBFILE_PRIORITY_core = "5"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_core = "1"
# Set a variable to get to the top of the metadata location
COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'