summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/flumotion/flumotion_0.4.1.bb17
1 files changed, 12 insertions, 5 deletions
diff --git a/meta-extras/packages/flumotion/flumotion_0.4.1.bb b/meta-extras/packages/flumotion/flumotion_0.4.1.bb
index 31f4052845..cb7ab10a81 100644
--- a/meta-extras/packages/flumotion/flumotion_0.4.1.bb
+++ b/meta-extras/packages/flumotion/flumotion_0.4.1.bb
@@ -1,13 +1,19 @@
DESCRIPTION = "Fluendo Streaming Server"
LICENSE = "GPL"
-DEPENDS = "gstreamer python-gst twisted python-pygtk2"
-RDEPENDS = "python-twisted-core python-twisted-web python-core python-gst"
-RDEPENDS_${PN}-gui = "${PN} python-pygtk"
-PR = "r4"
+DEPENDS = "gstreamer python-imaging python-gst twisted python-pygtk"
+RDEPENDS = "python-resource python-pprint python-threading \
+ python-imaging python-xml python-curses \
+ python-compression python-fcntl python-pygobject \
+ python-pickle python-netclient python-datetime \
+ python-crypt python-twisted-core python-twisted-web \
+ python-lang python-zopeinterface python-textutils \
+ python-gst python-misc"
+RDEPENDS_${PN}-gui = "${PN} python-pygtk python-pycairo"
+PR = "r9"
SRC_URI = "http://www.flumotion.net/src/flumotion/flumotion-${PV}.tar.bz2 \
file://python-path.patch;patch=1 \
- file://no-check-for-python-stuff.patch;patch=1"
+ file://no-check-for-python-stuff.patch;patch=1"
inherit autotools distutils-base pkgconfig
@@ -17,6 +23,7 @@ EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
PACKAGES =+ "flumotion-gui"
+FILES_${PN}-dbg += "${libdir}/flumotion/python/flumotion/extern/*/.debug/*"
FILES_${PN} = "${bindir} ${sbindir} ${libdir}/flumotion"
FILES_${PN}-dev += "${libdir}/pkgconfig"
FILES_${PN}-gui = "${bindir}/flumotion-admin ${bindir}/flumotion-tester \