aboutsummaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch')
-rw-r--r--meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch b/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch
deleted file mode 100644
index 2a10f13d40..0000000000
--- a/meta-extras/packages/xorg-xserver/xserver-kdrive-xomap/xcalibrate.patch
+++ /dev/null
@@ -1,73 +0,0 @@
----
- Xext/Makefile.am | 5
- Xext/xcalibrate.c | 262 +++++++++++++++++++++++++++++++++++++++++++++
- configure.ac | 8 +
- include/kdrive-config.h.in | 3
- mi/miinitext.c | 6 +
- 5 files changed, 283 insertions(+), 1 deletion(-)
-
-Index: xorg-server-1.1.99.3/mi/miinitext.c
-===================================================================
---- xorg-server-1.1.99.3.orig/mi/miinitext.c 2006-11-03 14:49:06.000000000 +0000
-+++ xorg-server-1.1.99.3/mi/miinitext.c 2007-01-27 17:59:40.000000000 +0000
-@@ -368,6 +368,9 @@ extern void ResExtensionInit(INITARGS);
- #ifdef DMXEXT
- extern void DMXExtensionInit(INITARGS);
- #endif
-+#ifdef XCALIBRATE
-+extern void XCalibrateExtensionInit(INITARGS);
-+#endif
- #ifdef XEVIE
- extern void XevieExtensionInit(INITARGS);
- #endif
-@@ -662,6 +665,9 @@ InitExtensions(argc, argv)
- #ifdef XSP
- if (!noXspExtension) XSPExtensionInit();
- #endif
-+#ifdef XCALIBRATE
-+ XCalibrateExtensionInit ();
-+#endif
- }
-
- void
-Index: xorg-server-1.1.99.3/configure.ac
-===================================================================
---- xorg-server-1.1.99.3.orig/configure.ac 2006-11-03 14:49:05.000000000 +0000
-+++ xorg-server-1.1.99.3/configure.ac 2007-01-29 22:58:18.000000000 +0000
-@@ -1584,7 +1590,7 @@ if test "$KDRIVE" = yes; then
- KDRIVE_LIB='$(top_builddir)/hw/kdrive/src/libkdrive.a'
- KDRIVE_OS_LIB='$(top_builddir)/hw/kdrive/linux/liblinux.a'
- KDRIVE_STUB_LIB='$(top_builddir)/hw/kdrive/src/libkdrivestubs.a'
-- KDRIVE_LIBS="$XSERVERLIBS_LIBS $DIX_LIB $XSP_LIB $KDRIVE_LIB $TSLIB_LIBS $KDRIVE_OS_LIB $KDRIVE_PURE_LIBS $KDRIVE_STUB_LIB"
-+ KDRIVE_LIBS="$XSERVERLIBS_LIBS $DIX_LIB $XSP_LIB $KDRIVE_LIB $TSLIB_LIBS $KDRIVE_PURE_LIBS $KDRIVE_OS_LIB $KDRIVE_STUB_LIB"
-
- # check if we can build Xephyr
- PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp, [xephyr="yes"], [xephyr="no"])
-Index: xorg-server-1.1.99.3/include/kdrive-config.h.in
-===================================================================
---- xorg-server-1.1.99.3.orig/include/kdrive-config.h.in 2006-11-03 14:49:06.000000000 +0000
-+++ xorg-server-1.1.99.3/include/kdrive-config.h.in 2007-01-27 17:59:40.000000000 +0000
-@@ -28,4 +28,7 @@
- /* Have the backtrace() functiln. */
- #undef HAVE_BACKTRACE
-
-+/* Enable XCalibrate extension */
-+#undef XCALIBRATE
-+
- #endif /* _KDRIVE_CONFIG_H_ */
-Index: xorg-server-1.1.99.3/Xext/Makefile.am
-===================================================================
---- xorg-server-1.1.99.3.orig/Xext/Makefile.am 2006-11-03 14:49:05.000000000 +0000
-+++ xorg-server-1.1.99.3/Xext/Makefile.am 2007-01-29 22:58:33.000000000 +0000
-@@ -81,6 +81,11 @@ BUILTIN_SRCS += $(XCALIBRATE_SRCS)
- # XCalibrare needs tslib
- endif
-
-+XCALIBRATE_SRCS = xcalibrate.c
-+if XCALIBRATE
-+BUILTIN_SRCS += $(XCALIBRATE_SRCS)
-+endif
-+
- # X EVent Interception Extension: allows accessibility helpers & composite
- # managers to intercept events from input devices and transform as needed
- # before the clients see them.