summaryrefslogtreecommitdiffstats
path: root/meta-extras/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/conf')
-rw-r--r--meta-extras/conf/machine/mx31litekit.conf14
-rw-r--r--meta-extras/conf/machine/nokia770.conf35
-rw-r--r--meta-extras/conf/machine/nokia800.conf30
-rw-r--r--meta-extras/conf/machine/om-gta01.conf48
-rw-r--r--meta-extras/conf/machine/om-gta02.conf49
5 files changed, 176 insertions, 0 deletions
diff --git a/meta-extras/conf/machine/mx31litekit.conf b/meta-extras/conf/machine/mx31litekit.conf
new file mode 100644
index 0000000000..2dc2883759
--- /dev/null
+++ b/meta-extras/conf/machine/mx31litekit.conf
@@ -0,0 +1,14 @@
+#@TYPE: Machine
+#@NAME: imx31 Lite Kit
+#@DESCRIPTION: Machine configuration for the imx31 based Lite Kit
+TARGET_ARCH = "arm"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te armv6"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-mx31"
+
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth irda screen touchscreen"
+
+IMAGE_FSTYPES ?= "tar.gz"
+SERIAL_CONSOLE = "-L 115200 ttymxc0"
+
+require conf/machine/include/tune-arm1136jf-s.inc
diff --git a/meta-extras/conf/machine/nokia770.conf b/meta-extras/conf/machine/nokia770.conf
new file mode 100644
index 0000000000..c8b4c3c912
--- /dev/null
+++ b/meta-extras/conf/machine/nokia770.conf
@@ -0,0 +1,35 @@
+#@TYPE: Machine
+#@NAME: Nokia 770 internet tablet
+#@DESCRIPTION: Machine configuration for the Nokia 770, an omap 1710 based tablet
+TARGET_ARCH = "arm"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te"
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-xomap"
+PREFERRED_PROVIDER_virtual/bootloader = ""
+
+XSERVER = "xserver-kdrive-xomap"
+
+# 800x480 is big enough for me
+GUI_MACHINE_CLASS = "bigscreen"
+
+require conf/machine/include/tune-arm926ejs.inc
+
+#size of the root partition (yes, it is 123 MB)
+ROOT_FLASH_SIZE = "123"
+EXTRA_IMAGECMD_jffs2_nokia770 = "--pad --little-endian --eraseblock=0x20000 -n"
+
+IMAGE_FSTYPES ?= "jffs2"
+
+# serial console port on devboard rev. B3
+SERIAL_CONSOLE = "115200 ttyS0"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-nokia800"
+
+#use this if you are using the nokia initfs
+ROOTFS_POSTPROCESS_COMMAND += " remove_init_link; "
+
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget usbhost screen vfat"
+MACHINE_EXTRA_RDEPENDS = "usbinit"
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "nokia770-init"
+
+KERNEL_IMAGE_MAXSIZE = "2097152"
diff --git a/meta-extras/conf/machine/nokia800.conf b/meta-extras/conf/machine/nokia800.conf
new file mode 100644
index 0000000000..fb2cd02b03
--- /dev/null
+++ b/meta-extras/conf/machine/nokia800.conf
@@ -0,0 +1,30 @@
+#@TYPE: Machine
+#@NAME: Nokia 800/810 internet tablet
+#@DESCRIPTION: Machine configuration for the Nokia 800/810
+TARGET_ARCH = "arm"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te armv6"
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-xomap"
+XSERVER = "xserver-kdrive-xomap"
+
+GUI_MACHINE_CLASS = "bigscreen"
+
+require conf/machine/include/tune-arm1136jf-s.inc
+
+ROOT_FLASH_SIZE = "174"
+EXTRA_IMAGECMD_jffs2_nokia800 = "--pad --little-endian --eraseblock=0x20000 -n"
+
+IMAGE_FSTYPES ?= "jffs2"
+
+SERIAL_CONSOLE = "-L 115200 ttyS0"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-nokia800"
+
+#use this if you are using the nokia initfs
+ROOTFS_POSTPROCESS_COMMAND += " remove_init_link; "
+
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget usbhost vfat"
+MACHINE_EXTRA_RDEPENDS = "cx3110x usbinit"
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "nokia770-init"
+
+KERNEL_IMAGE_MAXSIZE = "2097152"
diff --git a/meta-extras/conf/machine/om-gta01.conf b/meta-extras/conf/machine/om-gta01.conf
new file mode 100644
index 0000000000..f40457e226
--- /dev/null
+++ b/meta-extras/conf/machine/om-gta01.conf
@@ -0,0 +1,48 @@
+#-----------------------------------------------------------------------------
+#@TYPE: Machine
+#@NAME: FIC GTA01 (Neo1973)
+#@DESCRIPTION: Machine configuration for the FIC Neo1973/1 GSM phone
+#-----------------------------------------------------------------------------
+
+TARGET_ARCH = "arm"
+MACHINE_CLASS = "neo1973"
+PACKAGE_EXTRA_ARCHS = "armv4t fic-gta01 ${MACHINE_CLASS}"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-openmoko"
+UBOOT_ENTRYPOINT = "30008000"
+
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth gps usbgadget usbhost phone vfat ext2"
+MACHINE_DISPLAY_WIDTH_PIXELS = "480"
+MACHINE_DISPLAY_HEIGHT_PIXELS = "640"
+MACHINE_DISPLAY_ORIENTATION = "0"
+MACHINE_DISPLAY_PPI = "285"
+XSERVER = "xserver-kdrive-fbdev"
+
+MACHINE_EXTRA_RDEPENDS = "usbinit"
+# package machine specific modules
+MACHINE_EXTRA_RRECOMMENDS = "\
+ kernel-module-gta01-pm-bt \
+ kernel-module-gta01-pm-gps \
+ kernel-module-gta01-pm-gsm \
+ kernel-module-gta01kbd \
+ kernel-module-s3cmci \
+ kernel-module-snd-soc-neo1973-wm8753 \
+ kernel-module-snd-soc-smdk2440 \
+"
+
+# do not outcomment, we bypass the sysvinit.bb logic here -- see FIC GTA01 inittab
+#SERIAL_CONSOLE = "115200 ttySAC0"
+
+# used by some images
+ROOT_FLASH_SIZE = "60"
+
+# extra jffs2 tweaks
+IMAGE_FSTYPES ?= "jffs2"
+EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x4000 --pad -n"
+
+# build / upload tools
+#EXTRA_IMAGEDEPENDS += "dfu-util-native"
+
+# tune for S3C24x0
+include conf/machine/include/tune-arm920t.inc
+
diff --git a/meta-extras/conf/machine/om-gta02.conf b/meta-extras/conf/machine/om-gta02.conf
new file mode 100644
index 0000000000..55f4bec21d
--- /dev/null
+++ b/meta-extras/conf/machine/om-gta02.conf
@@ -0,0 +1,49 @@
+#-----------------------------------------------------------------------------
+#@TYPE: Machine
+#@NAME: FIC GTA02 (Neo1973)
+#@DESCRIPTION: Machine configuration for the FIC Neo1973/2 GSM phone
+#-----------------------------------------------------------------------------
+
+TARGET_ARCH = "arm"
+MACHINE_CLASS = "neo1973"
+PACKAGE_EXTRA_ARCHS = "armv4t fic-gta02 ${MACHINE_CLASS}"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-openmoko"
+PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-glamo"
+UBOOT_ENTRYPOINT = "30008000"
+
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth gps usbgadget usbhost phone wifi vfat ext2"
+MACHINE_DISPLAY_WIDTH_PIXELS = "480"
+MACHINE_DISPLAY_HEIGHT_PIXELS = "640"
+MACHINE_DISPLAY_ORIENTATION = "0"
+MACHINE_DISPLAY_PPI = "285"
+XSERVER = "xserver-kdrive-glamo xserver-kdrive-fbdev"
+
+# package machine specific modules
+MACHINE_EXTRA_RRECOMMENDS = "\
+ kernel-module-gta01-pm-bt \
+ kernel-module-gta01-pm-gps \
+ kernel-module-gta01-pm-gsm \
+ kernel-module-gta01kbd \
+ kernel-module-s3cmci \
+ kernel-module-snd-soc-neo1973-gta02-wm8753 \
+"
+
+SERIAL_CONSOLE = "115200 ttySAC2"
+
+# used by some images
+ROOT_FLASH_SIZE = "256"
+
+# extra jffs2 tweaks
+IMAGE_FSTYPES ?= "jffs2"
+EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 --pagesize=0x800 \
+ --no-cleanmarkers --pad -n ; sumtool --eraseblock=0x20000 --no-cleanmarkers \
+ --littleendian --pad \
+ -i ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
+ -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2.summary"
+
+# build / upload tools
+#EXTRA_IMAGEDEPENDS += "sjf2410-linux-native dfu-util-native"
+
+# tune for S3C24x0
+include conf/machine/include/tune-arm920t.inc