aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/wbxml
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-connectivity/wbxml')
-rw-r--r--meta-demoapps/recipes-connectivity/wbxml/files/no-doc-install.patch15
-rw-r--r--meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb24
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/wbxml/files/no-doc-install.patch b/meta-demoapps/recipes-connectivity/wbxml/files/no-doc-install.patch
new file mode 100644
index 0000000000..16084e60e6
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/wbxml/files/no-doc-install.patch
@@ -0,0 +1,15 @@
+--- wbxml2-0.9.2/Makefile.am.old 2007-01-03 19:50:24.000000000 +0000
++++ wbxml2-0.9.2/Makefile.am 2007-01-03 19:50:39.000000000 +0000
+@@ -24,9 +24,9 @@
+ TODO\
+ doxygen.h
+
+-install-data-local:
+- $(mkinstalldirs) $(DESTDIR)$(wbxmldocdir)/manual
+- cp -Rp doc/* $(DESTDIR)$(wbxmldocdir)/manual
++#install-data-local:
++# $(mkinstalldirs) $(DESTDIR)$(wbxmldocdir)/manual
++# cp -Rp doc/* $(DESTDIR)$(wbxmldocdir)/manual
+
+ dist-bz2: distdir
+ sed -e "s/tar.gz/tar.bz2/g" $(distdir)/wbxml2.spec > $(distdir)/wbxml2.spec.aux
diff --git a/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb b/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
new file mode 100644
index 0000000000..e3ac0017ff
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Parsing and Encoding of WBXML documents"
+DESCRIPTION = "The WBXML Library (aka libwbxml) contains a library and \
+its associated tools to Parse, Encode and Handle WBXML documents. The \
+WBXML format is a binary representation of XML, defined by the Wap \
+Forum, and used to reduce bandwidth in mobile communications."
+LICENSE = "GPLv2"
+
+DEPENDS = "libxml2 sed-native expat"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
+ file://no-doc-install.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ sed -i s:-I/usr/include::g Makefile
+ sed -i s:-I/usr/include::g */Makefile
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+