summaryrefslogtreecommitdiffstats
path: root/handbook/poky-doc-tools/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'handbook/poky-doc-tools/configure.ac')
-rw-r--r--handbook/poky-doc-tools/configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/handbook/poky-doc-tools/configure.ac b/handbook/poky-doc-tools/configure.ac
new file mode 100644
index 0000000000..0d15c8198c
--- /dev/null
+++ b/handbook/poky-doc-tools/configure.ac
@@ -0,0 +1,27 @@
+AC_PREREQ(2.53)
+AC_INIT(poky-doc-tools, 0.1, http://o-hand.com)
+AM_INIT_AUTOMAKE()
+
+AC_PATH_PROG(HAVE_XSLTPROC, xsltproc, no)
+if test x$HAVE_XSLTPROC = xno; then
+ AC_MSG_ERROR([Required xsltproc program not found])
+fi
+
+AC_PATH_PROG(HAVE_FOP, fop, no)
+if test x$HAVE_FOP = xno; then
+ AC_MSG_ERROR([Required fop program not found])
+fi
+
+AC_CHECK_FILE([/usr/share/xml/docbook/stylesheet/nwalsh/template/titlepage.xsl],HAVE_NWALSH="yes", HAVE_NWALSH="no")
+if test x$HAVE_FOP = xno; then
+ AC_MSG_ERROR([Required 'nwalsh' docbook stylesheets not found])
+fi
+
+AC_OUTPUT([
+Makefile
+common/Makefile
+])
+
+echo "
+ == poky-doc-tools $VERSION configured successfully. ==
+" \ No newline at end of file