summaryrefslogtreecommitdiffstats
path: root/handbook/poky-doc-tools/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'handbook/poky-doc-tools/common/Makefile.am')
-rw-r--r--handbook/poky-doc-tools/common/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/handbook/poky-doc-tools/common/Makefile.am b/handbook/poky-doc-tools/common/Makefile.am
new file mode 100644
index 0000000000..c6b154b144
--- /dev/null
+++ b/handbook/poky-doc-tools/common/Makefile.am
@@ -0,0 +1,21 @@
+SUPPORT_FILES = VeraMoBd.ttf VeraMoBd.xml \
+ VeraMono.ttf VeraMono.xml \
+ Vera.ttf Vera.xml \
+ draft.png titlepage.templates.xml \
+ poky-db-pdf.xsl poky.svg \
+ ohand-color.svg poky-handbook.png
+
+commondir = $(pkgdatadir)/common
+common_DATA = $(SUPPORT_FILES) fop-config.xml
+
+EXTRA_DIST = $(SUPPORT_FILES) fop-config.xml.in
+
+edit = sed -e 's,@datadir\@,$(pkgdatadir),g'
+
+fop-config.xml: fop-config.xml.in
+ rm -f fop-config.xml
+ $(edit) fop-config.xml.in > fop-config.xml
+
+
+clean-local:
+ rm -fr fop-config.xml \ No newline at end of file