summaryrefslogtreecommitdiffstats
path: root/handbook/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'handbook/Makefile')
-rw-r--r--handbook/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
index 2c593cf652..4a4dd7e83f 100644
--- a/handbook/Makefile
+++ b/handbook/Makefile
@@ -1,4 +1,4 @@
-all: html pdf
+all: html pdf tarball
pdf:
@@ -23,3 +23,9 @@ tarball: html
validate:
xmllint --postvalid --xinclude --noout poky-handbook.xml
+
+OUTPUTS = poky-handbook.tgz poky-handbook.html poky-handbook.pdf
+SOURCES = *.png *.xml *.css *.svg
+
+publish:
+ scp -r $(OUTPUTS) $(SOURCES) o-hand.com:/srv/www/pokylinux.org/doc/