aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/bash/bash-4.2/run-ptest2
-rw-r--r--meta/recipes-extended/bash/bash.inc1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/bash/bash-4.2/run-ptest b/meta/recipes-extended/bash/bash-4.2/run-ptest
index 66f1eee543..8dd3b9981d 100644
--- a/meta/recipes-extended/bash/bash-4.2/run-ptest
+++ b/meta/recipes-extended/bash/bash-4.2/run-ptest
@@ -1,2 +1,2 @@
#!/bin/sh
-echo Makefile: | make -f Makefile -f - -k THIS_SH=/bin/bash BUILD_DIR=. runtest
+make -k THIS_SH=/bin/bash BUILD_DIR=. runtest
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index c619f824e9..2f4519cdda 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -40,6 +40,7 @@ do_install_append () {
do_install_ptest () {
make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
cp ${B}/Makefile ${D}${PTEST_PATH}
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
}
pkg_postinst_${PN} () {