aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/mdadm/files/fix-z-now.patch15
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.1.4.bb5
2 files changed, 18 insertions, 2 deletions
diff --git a/meta/recipes-extended/mdadm/files/fix-z-now.patch b/meta/recipes-extended/mdadm/files/fix-z-now.patch
new file mode 100644
index 0000000000..3cd606b528
--- /dev/null
+++ b/meta/recipes-extended/mdadm/files/fix-z-now.patch
@@ -0,0 +1,15 @@
+Fix -z now is really a LD option, not a gcc option so use -Wl to pass it to LD
+
+Created-by: Saul Wold <saul.wold@intel.com>
+
+--- Makefile.orig 2010-08-31 13:52:46.277764099 -0700
++++ Makefile 2010-08-31 14:02:28.218014078 -0700
+@@ -167,7 +167,7 @@
+
+ # use '-z now' to guarantee no dynamic linker interactions with the monitor thread
+ mdmon : $(MON_OBJS)
+- $(CC) $(LDFLAGS) $(MON_LDFLAGS) -z now -o mdmon $(MON_OBJS) $(LDLIBS)
++ $(CC) $(LDFLAGS) $(MON_LDFLAGS) -Wl,-z,now -o mdmon $(MON_OBJS) $(LDLIBS)
+ msg.o: msg.c msg.h
+
+ test_stripe : restripe.c mdadm.h
diff --git a/meta/recipes-extended/mdadm/mdadm_3.1.4.bb b/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
index b28e96b759..94c4f6cde9 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
@@ -8,9 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
-PR = "r0"
+PR = "r1"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/raid/mdadm/${PN}-${PV}.tar.bz2"
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/raid/mdadm/${PN}-${PV}.tar.bz2 \
+ file://fix-z-now.patch;striplevel=0"
CFLAGS += "-fno-strict-aliasing"