aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/conf/layer.conf1
-rw-r--r--meta/recipes-connectivity/connman/connman-conf.bb18
-rw-r--r--meta/recipes-connectivity/connman/connman-conf/qemuall/main.conf3
3 files changed, 22 insertions, 0 deletions
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
index 78ceae9db6..3259e5c712 100644
--- a/meta/conf/layer.conf
+++ b/meta/conf/layer.conf
@@ -22,6 +22,7 @@ SIGGEN_EXCLUDERECIPES_ABISAFE += " \
shadow-securetty \
opkg-config-base \
netbase \
+ connman-conf \
formfactor \
xserver-xf86-config \
pointercal \
diff --git a/meta/recipes-connectivity/connman/connman-conf.bb b/meta/recipes-connectivity/connman/connman-conf.bb
new file mode 100644
index 0000000000..7c7ef263ce
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman-conf.bb
@@ -0,0 +1,18 @@
+#connman config to ignore wired interfaces on qemu machines
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI_append_qemuall = " file://main.conf"
+
+PR = "r0"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_install() {
+ #Blacklist ethn network interface in case of qemu* machines
+ if test -e ${WORKDIR}/main.conf; then
+ install -d ${D}${sysconfdir}/connman
+ install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
+ fi
+}
diff --git a/meta/recipes-connectivity/connman/connman-conf/qemuall/main.conf b/meta/recipes-connectivity/connman/connman-conf/qemuall/main.conf
new file mode 100644
index 0000000000..01973e7f71
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman-conf/qemuall/main.conf
@@ -0,0 +1,3 @@
+[General]
+
+NetworkInterfaceBlacklist = eth