aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb29
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb26
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.2.bb33
3 files changed, 0 insertions, 88 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
deleted file mode 100644
index 1f1b8de942..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-require recipes-kernel/linux/linux-yocto.inc
-
-KBRANCH = "standard/preempt-rt/base"
-KBRANCH_qemuppc = "standard/preempt-rt/qemu-ppc32"
-
-LINUX_VERSION ?= "3.2.32"
-LINUX_KERNEL_TYPE = "preempt-rt"
-
-KMETA = "meta"
-
-SRCREV_machine ?= "d8f7347b67d909a999391c4b6f64447b0ccdc86a"
-SRCREV_machine_qemuppc ?= "65c57e1a8656830260aa56a25bc8512dcb68258a"
-SRCREV_meta ?= "e7f2fdc48f8808887175f0328274a2668084738c"
-
-PR = "${INC_PR}.0"
-PV = "${LINUX_VERSION}+git${SRCPV}"
-
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
-
-# Omit broken machines from COMPATIBLE_MACHINE
-# qemuppc hangs at boot
-# qemumips panics at boot
-COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
-
-# Functionality flags
-KERNEL_FEATURES_append = "features/netfilter/netfilter.scc"
-KERNEL_FEATURES_append = " features/taskstats/taskstats.scc"
-KERNEL_FEATURES_append_qemux86 = " cfg/sound.scc"
-KERNEL_FEATURES_append_qemux86-64 = " cfg/sound.scc"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
deleted file mode 100644
index 00f706b002..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-require recipes-kernel/linux/linux-yocto.inc
-
-# We need lzma (as CONFIG_KERNEL_LZMA=y)
-DEPENDS += "xz-native"
-
-KBRANCH_DEFAULT = "standard/tiny"
-KBRANCH = "${KBRANCH_DEFAULT}"
-LINUX_KERNEL_TYPE = "tiny"
-KCONFIG_MODE = "--allnoconfig"
-
-LINUX_VERSION ?= "3.2.32"
-
-KMETA = "meta"
-
-SRCREV_machine ?= "c07ec7159c3ede723953b0d603a7bb55d8614b44"
-SRCREV_meta ?= "e7f2fdc48f8808887175f0328274a2668084738c"
-
-PR = "${INC_PR}.0"
-PV = "${LINUX_VERSION}+git${SRCPV}"
-
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
-
-COMPATIBLE_MACHINE = "(qemux86)"
-
-# Functionality flags
-KERNEL_FEATURES = ""
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.2.bb b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
deleted file mode 100644
index d080a6918a..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto_3.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-require recipes-kernel/linux/linux-yocto.inc
-
-KBRANCH = "standard/default/base"
-KBRANCH_qemux86 = "standard/default/common-pc/base"
-KBRANCH_qemux86-64 = "standard/default/common-pc-64/base"
-KBRANCH_qemuppc = "standard/default/qemu-ppc32"
-KBRANCH_qemumips = "standard/default/mti-malta32-be"
-KBRANCH_qemuarm = "standard/default/arm-versatile-926ejs"
-
-LINUX_VERSION ?= "3.2.32"
-
-SRCREV_machine_qemuarm ?= "ec68698f59bed87be4e13954d5d2b9dc1f314b45"
-SRCREV_machine_qemumips ?= "ce21a2ab86277e410fd2229a10c45be6c9d0aa17"
-SRCREV_machine_qemuppc ?= "edd27681039f2077d83eb02d7c1c44afb7b6224f"
-SRCREV_machine_qemux86 ?= "2223d2fb00365c168ec380bdcbef05ef89751c85"
-SRCREV_machine_qemux86-64 ?= "2d7956d7e3d15f69c923315c175847813f353d39"
-SRCREV_machine ?= "6970a8f4f7caa2633aa1ae0b51732b246eb581ef"
-SRCREV_meta ?= "e7f2fdc48f8808887175f0328274a2668084738c"
-
-PR = "${INC_PR}.1"
-PV = "${LINUX_VERSION}+git${SRCPV}"
-
-KMETA = "meta"
-
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
-
-COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
-
-# Functionality flags
-KERNEL_FEATURES_append=" features/netfilter/netfilter.scc"
-KERNEL_FEATURES_append=" features/taskstats/taskstats.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"