aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/classes/kernel-yocto.bbclass2
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb6
2 files changed, 5 insertions, 3 deletions
diff --git a/meta/classes/kernel-yocto.bbclass b/meta/classes/kernel-yocto.bbclass
index d513ad2b63..fcc00e3d47 100644
--- a/meta/classes/kernel-yocto.bbclass
+++ b/meta/classes/kernel-yocto.bbclass
@@ -262,6 +262,8 @@ python do_kernel_configcheck() {
# set the default to 'meta'. Otherwise, kconf_check is not passed a valid
# meta-series for processing
kmeta = d.getVar( "KMETA", True ) or "meta"
+ if not os.path.exists(kmeta):
+ kmeta = "." + kmeta
pathprefix = "export PATH=%s:%s; " % (d.getVar('PATH', True), "${S}/scripts/util/")
cmd = d.expand("cd ${S}; kconf_check -config- %s/meta-series ${S} ${B}" % kmeta)
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index c414fed319..f6fca9ee33 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -2,11 +2,11 @@ DESCRIPTION = "Scripts and utilities for managing Yocto branched kernels."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=d8d1d729a70cd5f52972f8884b80743d"
-DEPENDS = "git-native guilt-native"
+DEPENDS = "git-native"
-SRCREV = "fbcdcb8e23c38352b46235598f34d7b345f458f1"
+SRCREV = "60a894e1018ab55f4014fbfb2a56624d26d94504"
PR = "r12"
-PV = "0.1+git${SRCPV}"
+PV = "0.2+git${SRCPV}"
inherit native