aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-gnome/gtk+/gtk+.inc8
-rw-r--r--meta/recipes-gnome/gtk+/gtk+_2.24.15.bb10
2 files changed, 1 insertions, 17 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+.inc b/meta/recipes-gnome/gtk+/gtk+.inc
index f05838a173..84edaf38a6 100644
--- a/meta/recipes-gnome/gtk+/gtk+.inc
+++ b/meta/recipes-gnome/gtk+/gtk+.inc
@@ -10,8 +10,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
SECTION = "libs"
-PROVIDES_class-native = "virtual/gtk-update-icon-cache-native"
-
X11DEPENDS = "virtual/libx11 libxext libxcursor libxrandr libxdamage libxrender libxcomposite"
DEPENDS = "glib-2.0 pango atk jpeg libpng gdk-pixbuf-native docbook-utils-native \
libgcrypt cairo gdk-pixbuf"
@@ -81,12 +79,6 @@ do_install () {
mv ${D}${bindir}/gtk-update-icon-cache ${D}${bindir}/gtk-update-icon-cache-2.0
}
-do_install_append_class-native () {
- # Ideally we'd use alternatives in the sysroot, but they don't work.
- # As we know we don't have a native GTK+ 3 (yet), make a symlink instead.
- ln -s gtk-update-icon-cache-2.0 ${D}${bindir}/gtk-update-icon-cache
-}
-
SYSROOT_PREPROCESS_FUNCS += "gtk_sysroot_preprocess"
gtk_sysroot_preprocess () {
diff --git a/meta/recipes-gnome/gtk+/gtk+_2.24.15.bb b/meta/recipes-gnome/gtk+/gtk+_2.24.15.bb
index 4e045e4fef..02d66f86b9 100644
--- a/meta/recipes-gnome/gtk+/gtk+_2.24.15.bb
+++ b/meta/recipes-gnome/gtk+/gtk+_2.24.15.bb
@@ -28,7 +28,7 @@ SRC_URI = "http://download.gnome.org/sources/gtk+/2.24/gtk+-${PV}.tar.xz \
# file://combo-arrow-size.patch;striplevel=0
# file://configurefix.patch
-PR = "r0"
+PR = "r1"
SRC_URI[md5sum] = "68f034fb4f68086790d7488cf00e71c8"
SRC_URI[sha256sum] = "d7e1c6d6ae6baa48c88441fe52b73b0fb6008763644867d59b049bafb0cf771b"
@@ -38,14 +38,6 @@ EXTRA_OECONF = "--without-libtiff --without-libjasper --enable-xkb --disable-gli
LIBV = "2.10.0"
PACKAGES_DYNAMIC += "^gtk-immodule-.* ^gtk-printbackend-.*"
-BBCLASSEXTEND = "native"
-RRECOMMENDS_${PN}_class-native = ""
-DEPENDS_class-native = "glib-2.0-native atk-native pango-native cairo-native gdk-pixbuf-native"
-
-do_install_append_class-native () {
- create_wrapper ${D}/${bindir}/gtk-update-icon-cache-2.0 \
- GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
-}
python populate_packages_prepend () {
gtk_libdir = d.expand('${libdir}/gtk-2.0/${LIBV}')