aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/file/file_5.16.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.16.bb b/meta/recipes-devtools/file/file_5.16.bb
index 46dbf88f8d..a15d952e3d 100644
--- a/meta/recipes-devtools/file/file_5.16.bb
+++ b/meta/recipes-devtools/file/file_5.16.bb
@@ -32,5 +32,9 @@ do_install_append_class-native() {
--magic-file ${datadir}/misc/magic.mgc
}
+do_install_append_class-nativesdk() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
BBCLASSEXTEND = "native nativesdk"