summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-10-11 14:33:54 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-11 22:53:45 +0100
commitb5f744c5d6fea4e5f33545d1dbf40d2f964cb786 (patch)
treea05e7bba4267a69335aa0b3fd57100c164c1ac66 /meta
parent6b53fbcc205346be60ea0a8e01c7cb0bbeeba55a (diff)
downloadopenembedded-core-b5f744c5d6fea4e5f33545d1dbf40d2f964cb786.tar.gz
python: fix for host contamination issue while cross compiling
This fixes [BUGID #385] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python.inc2
-rw-r--r--meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch27
-rw-r--r--meta/recipes-devtools/python/python_2.6.5.bb3
3 files changed, 30 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python.inc b/meta/recipes-devtools/python/python.inc
index 682bd5a2da..62a6ba1589 100644
--- a/meta/recipes-devtools/python/python.inc
+++ b/meta/recipes-devtools/python/python.inc
@@ -4,7 +4,7 @@ LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
# bump this on every change in contrib/python/generate-manifest-2.6.py
-INC_PR = "ml8"
+INC_PR = "nk0"
DEFAULT_PREFERENCE = "-26"
diff --git a/meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch b/meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch
new file mode 100644
index 0000000000..30aa50dd44
--- /dev/null
+++ b/meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch
@@ -0,0 +1,27 @@
+The poison directories patch has detected library path issue while
+compiling the python in cross environment, as seen bellow.
+
+warning: library search path "/usr/lib/termcap" is unsafe for cross-compilation
+
+This Patch fixes this issue in the python build environment.
+11 Oct 2010
+Nitin A Kamble <nitin.a.kamble@intel.com>
+
+Index: Python-2.6.5/setup.py
+===================================================================
+--- Python-2.6.5.orig/setup.py
++++ Python-2.6.5/setup.py
+@@ -591,12 +591,10 @@ class PyBuildExt(build_ext):
+ readline_libs.append('ncurses')
+ elif self.compiler.find_library_file(lib_dirs, 'curses'):
+ readline_libs.append('curses')
+- elif self.compiler.find_library_file(lib_dirs +
+- ['/usr/lib/termcap'],
++ elif self.compiler.find_library_file(lib_dirs,
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ else:
diff --git a/meta/recipes-devtools/python/python_2.6.5.bb b/meta/recipes-devtools/python/python_2.6.5.bb
index 9658fd48dc..674b673f94 100644
--- a/meta/recipes-devtools/python/python_2.6.5.bb
+++ b/meta/recipes-devtools/python/python_2.6.5.bb
@@ -2,7 +2,7 @@ require python.inc
DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -12,6 +12,7 @@ SRC_URI = "\
file://03-fix-tkinter-detection.patch \
file://04-default-is-optimized.patch \
file://05-enable-ctypes-cross-build.patch \
+ file://06-avoid_usr_lib_termcap_path_in_linking.patch \
file://99-ignore-optimization-flag.patch \
file://sitecustomize.py \
"