summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-11-04 19:45:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:32:43 +0000
commit7d76d7d90f8e832ddaaebfae125c7f9aecfcac9f (patch)
tree59bcbd4493846356df0612691f3b1ae4dede8094 /meta
parente3d2974348bd830ec2fcf84ea08cbf38abbc0327 (diff)
downloadopenembedded-core-7d76d7d90f8e832ddaaebfae125c7f9aecfcac9f.tar.gz
at: modify sources in do_patch
Instead of copying the forked source files into ${S} in do_compile_prepend(), do it in a do_patch() postfunc. This ensures that the source archiver sees the changes for compliance and legal verification. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/at/at_3.1.16.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/at/at_3.1.16.bb b/meta/recipes-extended/at/at_3.1.16.bb
index 0512bcb836..b11b587fcf 100644
--- a/meta/recipes-extended/at/at_3.1.16.bb
+++ b/meta/recipes-extended/at/at_3.1.16.bb
@@ -47,10 +47,10 @@ INITSCRIPT_PARAMS = "defaults"
SYSTEMD_SERVICE_${PN} = "atd.service"
-
-do_compile_prepend () {
+copy_sources() {
cp -f ${WORKDIR}/posixtm.[ch] ${S}
}
+do_patch[postfuncs] += "copy_sources"
do_install () {
oe_runmake -e "IROOT=${D}" install