summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-10-11 00:26:12 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-11 22:57:00 +0100
commit5ae1e2c9e881f92901ea66b78c4a5b3f08cd07d2 (patch)
tree3fb973d6f99000cff83e46f94ff0c1d5b84fc353 /meta
parent149f2262135ca87608783a8801c9c2d978d8c8ef (diff)
downloadopenembedded-core-5ae1e2c9e881f92901ea66b78c4a5b3f08cd07d2.tar.gz
mpc8315e-rdb: create machine and tuning configuration
BUGID: 423 Introduce the basic mpc8315e BSP. By default this BSP uses the basic 603 tuning and soft-float. There are issues with the e300 tuning and eglibc, and the compiler. Subsequent commits will further tune this BSP. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc3
-rw-r--r--meta/conf/machine/include/tune-ppce300c2.inc2
-rw-r--r--meta/conf/machine/mpc8315e-rdb.conf16
-rw-r--r--meta/recipes-kernel/linux/linux-wrs_git.bb5
4 files changed, 23 insertions, 3 deletions
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index 5f36c7b5e7..67bf4c419b 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -90,7 +90,8 @@ SRCREV_machine_pn-linux-wrs_qemux86-64 ?= "0431115c9d720fee5bb105f6a7411efb4f851
SRCREV_machine_pn-linux-wrs_emenlow ?= "aae69fdf104b0a9d7b3710f808aac6ab303490f7"
SRCREV_machine_pn-linux-wrs_atom-pc ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
SRCREV_machine_pn-linux-wrs_routerstationpro ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
-SRCREV_meta_pn-linux-wrs ?= "bfef596973ae436db9132065eaab2228c98f938b"
+SRCREV_machine_pn-linux-wrs_mpc8315e-rdb ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
+SRCREV_meta_pn-linux-wrs ?= "134a33e3a43579114ca5263e34c18a5d6854d085"
SRCREV_pn-linux-libc-headers-wrs ??= "09a39c638dd65dc27c549c119abe1af2631b2ae0"
SRCREV_pn-matchbox-config-gtk ??= "2081"
SRCREV_pn-matchbox-desktop-sato ??= "76"
diff --git a/meta/conf/machine/include/tune-ppce300c2.inc b/meta/conf/machine/include/tune-ppce300c2.inc
new file mode 100644
index 0000000000..067a7b100c
--- /dev/null
+++ b/meta/conf/machine/include/tune-ppce300c2.inc
@@ -0,0 +1,2 @@
+TARGET_CC_ARCH = "-mcpu=e300c2 -msoft-float"
+BASE_PACKAGE_ARCH = "ppce300"
diff --git a/meta/conf/machine/mpc8315e-rdb.conf b/meta/conf/machine/mpc8315e-rdb.conf
new file mode 100644
index 0000000000..a2aeea92a5
--- /dev/null
+++ b/meta/conf/machine/mpc8315e-rdb.conf
@@ -0,0 +1,16 @@
+#@TYPE: Machine
+#@DESCRIPTION: Machine configuration for running
+
+TARGET_ARCH = "powerpc"
+PACKAGE_EXTRA_ARCHS = "ppce300"
+TARGET_FPU = "spe"
+
+require conf/machine/include/tune-ppc603e.inc
+
+KERNEL_IMAGETYPE = "uImage"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-wrs"
diff --git a/meta/recipes-kernel/linux/linux-wrs_git.bb b/meta/recipes-kernel/linux/linux-wrs_git.bb
index f99be25c75..00e74022ef 100644
--- a/meta/recipes-kernel/linux/linux-wrs_git.bb
+++ b/meta/recipes-kernel/linux/linux-wrs_git.bb
@@ -27,12 +27,13 @@ WRMACHINE_qemumips = "mti_malta32_be"
WRMACHINE_qemuarm = "arm_versatile_926ejs"
WRMACHINE_atom-pc = "common_pc"
WRMACHINE_routerstationpro = "routerstationpro"
+WRMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro|mpc8315e-rdb)"
LINUX_VERSION = "v2.6.34"
LINUX_VERSION_EXTENSION = "-wr-${LINUX_KERNEL_TYPE}"
-PR = "r8"
+PR = "r9"
S = "${WORKDIR}/linux"
B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"