summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-10-10 14:11:07 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-11 22:56:28 +0100
commit149f2262135ca87608783a8801c9c2d978d8c8ef (patch)
tree64e227daee6dca157702d54b8914a2508e9471ac /meta
parentb5f744c5d6fea4e5f33545d1dbf40d2f964cb786 (diff)
downloadopenembedded-core-149f2262135ca87608783a8801c9c2d978d8c8ef.tar.gz
routerstationpro: create machine conf and compatibility
BUGID: 422 Add the machine configuration and kernel infrastructure for building the routerstation pro BSP. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc1
-rw-r--r--meta/conf/machine/routerstationpro.conf23
-rw-r--r--meta/recipes-kernel/linux/linux-wrs_git.bb8
3 files changed, 30 insertions, 2 deletions
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index c325260c6d..5f36c7b5e7 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -89,6 +89,7 @@ SRCREV_machine_pn-linux-wrs_qemux86 ?= "0431115c9d720fee5bb105f6a7411efb4f851d26
SRCREV_machine_pn-linux-wrs_qemux86-64 ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
SRCREV_machine_pn-linux-wrs_emenlow ?= "aae69fdf104b0a9d7b3710f808aac6ab303490f7"
SRCREV_machine_pn-linux-wrs_atom-pc ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
+SRCREV_machine_pn-linux-wrs_routerstationpro ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
SRCREV_meta_pn-linux-wrs ?= "bfef596973ae436db9132065eaab2228c98f938b"
SRCREV_pn-linux-libc-headers-wrs ??= "09a39c638dd65dc27c549c119abe1af2631b2ae0"
SRCREV_pn-matchbox-config-gtk ??= "2081"
diff --git a/meta/conf/machine/routerstationpro.conf b/meta/conf/machine/routerstationpro.conf
new file mode 100644
index 0000000000..ecacc9b873
--- /dev/null
+++ b/meta/conf/machine/routerstationpro.conf
@@ -0,0 +1,23 @@
+#@TYPE: Machine
+#@NAME: mti_malta32_be MIPS
+#@DESCRIPTION: mti_malta32_be
+
+TARGET_ARCH = "mips"
+
+require conf/machine/include/tune-mips32.inc
+
+MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 \
+ serial usbgadget"
+
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-wrs"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
+
+IMAGE_ROOTFS_SIZE_ext3 = "2000000"
+IMAGE_FSTYPES ?= "jffs2 tar.bz2"
+
diff --git a/meta/recipes-kernel/linux/linux-wrs_git.bb b/meta/recipes-kernel/linux/linux-wrs_git.bb
index f6b0aead55..f99be25c75 100644
--- a/meta/recipes-kernel/linux/linux-wrs_git.bb
+++ b/meta/recipes-kernel/linux/linux-wrs_git.bb
@@ -26,12 +26,13 @@ WRMACHINE_qemuppc = "qemu_ppc32"
WRMACHINE_qemumips = "mti_malta32_be"
WRMACHINE_qemuarm = "arm_versatile_926ejs"
WRMACHINE_atom-pc = "common_pc"
+WRMACHINE_routerstationpro = "routerstationpro"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro)"
LINUX_VERSION = "v2.6.34"
LINUX_VERSION_EXTENSION = "-wr-${LINUX_KERNEL_TYPE}"
-PR = "r7"
+PR = "r8"
S = "${WORKDIR}/linux"
B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"
@@ -166,6 +167,9 @@ do_wrlinux_configcheck() {
}
do_wrlinux_link_vmlinux() {
+ if [ ! -d "${B}/arch/${ARCH}/boot" ]; then
+ mkdir ${B}/arch/${ARCH}/boot
+ fi
cd ${B}/arch/${ARCH}/boot
ln -sf ../../../vmlinux
}