aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-06-28 15:58:40 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-29 14:44:26 +0100
commit7d24ef3454d2bcdf175c17206c8016bafe5e9372 (patch)
treede0e349e603b229da57aa60700730262a93e2392 /meta
parent8c29862d932176a94686372414d2e05f3a6728d3 (diff)
downloadopenembedded-core-7d24ef3454d2bcdf175c17206c8016bafe5e9372.tar.gz
connman: Upgrade to version 0.75
Enable ofono plugin. Adopt some logic in meta-oe on connman plugin runtime dependency. Remove the fix-shutdown-ap-disconnect.patch since the original logic no longer exists. Add Upstream-Status information for patches. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/connman/connman-0.65/fix-shutdown-ap-disconnect.patch42
-rw-r--r--meta/recipes-connectivity/connman/connman-0.75/add_xuser_dbus_permission.patch (renamed from meta/recipes-connectivity/connman/connman-0.65/add_xuser_dbus_permission.patch)2
-rw-r--r--meta/recipes-connectivity/connman/connman-0.75/connman (renamed from meta/recipes-connectivity/connman/connman-0.65/connman)0
-rw-r--r--meta/recipes-connectivity/connman/connman-0.75/dbusperms.patch (renamed from meta/recipes-connectivity/connman/connman-0.65/dbusperms.patch)2
-rw-r--r--meta/recipes-connectivity/connman/connman.inc14
-rw-r--r--meta/recipes-connectivity/connman/connman_0.75.bb (renamed from meta/recipes-connectivity/connman/connman_0.65.bb)8
6 files changed, 20 insertions, 48 deletions
diff --git a/meta/recipes-connectivity/connman/connman-0.65/fix-shutdown-ap-disconnect.patch b/meta/recipes-connectivity/connman/connman-0.65/fix-shutdown-ap-disconnect.patch
deleted file mode 100644
index a0ad0991df..0000000000
--- a/meta/recipes-connectivity/connman/connman-0.65/fix-shutdown-ap-disconnect.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Schedule delayed scan when being disconnected from an AP
-
-When being disconnected from an AP, a delayed scan is scheduled to make
-sure the AP is still there. wpa_supplicant removes a BSS from its bss list
-when it disappears from the scan results twice in a row.
-
-Author: Samuel Ortiz <sameo@linux.intel.com>
-Ported by Dongxiao Xu <dongxiao.xu@intel.com>
-
-diff -ruN connman-0.56-orig/plugins/supplicant.c connman-0.56/plugins/supplicant.c
---- connman-0.56-orig/plugins/supplicant.c 2010-09-25 15:08:21.242927383 +0800
-+++ connman-0.56/plugins/supplicant.c 2010-09-25 15:12:46.346136858 +0800
-@@ -2184,6 +2184,15 @@
- scanning == TRUE ? "started" : "finished");
- }
-
-+static gboolean delayed_scan(gpointer user_data)
-+{
-+ struct supplicant_task *task = user_data;
-+
-+ supplicant_scan(task->device);
-+
-+ return FALSE;
-+}
-+
- static void state_change(struct supplicant_task *task, DBusMessage *msg)
- {
- DBusError error;
-@@ -2277,7 +2286,13 @@
- task_connect(task);
- } else
- task->network = NULL;
-+ } else {
-+ if (task->state == WPA_DISCONNECTED)
-+ g_timeout_add_seconds(10, delayed_scan, task);
-+
-+ remove_network(task);
- }
-+
- break;
-
- default:
diff --git a/meta/recipes-connectivity/connman/connman-0.65/add_xuser_dbus_permission.patch b/meta/recipes-connectivity/connman/connman-0.75/add_xuser_dbus_permission.patch
index 787d49ba8d..764c689fcc 100644
--- a/meta/recipes-connectivity/connman/connman-0.65/add_xuser_dbus_permission.patch
+++ b/meta/recipes-connectivity/connman/connman-0.75/add_xuser_dbus_permission.patch
@@ -1,6 +1,8 @@
Some platform (like atom-pc) enables rootless X,
thus we need to add the xuser in the list.
+Upstream-Status: Inappropriate [configuration]
+
Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
diff -ruN connman-0.65-orig/src/connman-dbus.conf connman-0.65/src/connman-dbus.conf
diff --git a/meta/recipes-connectivity/connman/connman-0.65/connman b/meta/recipes-connectivity/connman/connman-0.75/connman
index f01bf371c2..f01bf371c2 100644
--- a/meta/recipes-connectivity/connman/connman-0.65/connman
+++ b/meta/recipes-connectivity/connman/connman-0.75/connman
diff --git a/meta/recipes-connectivity/connman/connman-0.65/dbusperms.patch b/meta/recipes-connectivity/connman/connman-0.75/dbusperms.patch
index 100af0367b..c331654de8 100644
--- a/meta/recipes-connectivity/connman/connman-0.65/dbusperms.patch
+++ b/meta/recipes-connectivity/connman/connman-0.75/dbusperms.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Inappropriate [configuration]
+
Index: git/src/connman-dbus.conf
===================================================================
--- git.orig/src/connman-dbus.conf 2009-05-26 00:34:35.000000000 +0100
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index fb970ed1eb..ccff573568 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -14,7 +14,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
file://src/main.c;beginline=1;endline=20;md5=4b55b550fa6b33cc2055ef30dd262b3e"
DEPENDS = "libgdbus dbus glib-2.0 hal iptables"
-RDEPENDS_${PN} = "wpa-supplicant resolvconf"
INITSCRIPT_NAME = "connman"
INITSCRIPT_PARAMS = "start 05 5 2 3 . stop 22 0 1 6 ."
@@ -40,7 +39,18 @@ FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
${libdir}/connman/scripts/.debug"
python populate_packages_prepend() {
+ depmap = dict( wifi="wpa-supplicant", bluetooth="bluez4", ofono="ofono" )
+ packages = []
+ hook = lambda file,pkg,b,c,d:packages.append((file,pkg))
+
plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
plugin_name = bb.data.expand('${PN}-plugin-%s', d)
- do_split_packages(d, plugin_dir, '^(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
+
+ do_split_packages(d, plugin_dir, '^(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='', hook=hook )
+
+ for (file, package) in packages:
+ plugintype = package.split( '-' )[-1]
+ if plugintype in depmap:
+ bb.note( "Adding rdependency on %s to package %s" % ( depmap[plugintype], package ) )
+ bb.data.setVar("RDEPENDS_%s" % package, depmap[plugintype], d)
}
diff --git a/meta/recipes-connectivity/connman/connman_0.65.bb b/meta/recipes-connectivity/connman/connman_0.75.bb
index 852f8dc873..75ef5b54b6 100644
--- a/meta/recipes-connectivity/connman/connman_0.65.bb
+++ b/meta/recipes-connectivity/connman/connman_0.75.bb
@@ -1,5 +1,5 @@
require connman.inc
-PR = "r1"
+PR = "r0"
EXTRA_OECONF += "\
ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
@@ -16,14 +16,14 @@ EXTRA_OECONF += "\
--disable-udev \
--disable-polkit \
--enable-client \
+ --enable-ofono \
--prefix=/usr --sysconfdir=/etc --localstatedir=/var"
SRC_URI = "\
${KERNELORG_MIRROR}/linux/network/connman/connman-${PV}.tar.gz \
- file://fix-shutdown-ap-disconnect.patch \
file://add_xuser_dbus_permission.patch \
file://connman \
"
-SRC_URI[md5sum] = "bd714da295ed2d2d91a49539f4c4fa3a"
-SRC_URI[sha256sum] = "a1c1d93da6bb4c2d8ae53293b06f237e02f5e796d2bba73ec639a466d05259c3"
+SRC_URI[md5sum] = "9973cb89a11fff6b51fc85b51c13b711"
+SRC_URI[sha256sum] = "b15361237f7ec8092fb0e55d4585550ab35491485edaf10ddd032d6e36299db7"