aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2017-07-20 16:55:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-24 09:12:28 +0100
commit3d5f11f0a1fd036e28a1d3f0c3169d8e21cc1358 (patch)
tree0c89d31f8395544511412f71c40b168078eb8954 /meta
parentf147b2502ae53d63a884a46e994ae18e12ec4ef6 (diff)
downloadopenembedded-core-3d5f11f0a1fd036e28a1d3f0c3169d8e21cc1358.tar.gz
ffmpeg: fix pkg-config utilization
in config.log we can see: WARNING: aarch64-linaro-linux-pkg-config not found, library detection may fail. ffmpeg configure script is not looking for pkg-config at the rigt place since it is assuming cross compilation. let's force its value in the recipe. This patches 'fixes' library detection, so it also adds: --disable-libxcb --disable-libxcb-shm --disable-libxcb-xfixes --disable-libxcb-shape Which were dangling configure options, which started to be enabled after the pkg-config fix, so they need now to be explicitely disabled. Follow up patch will enable these options when DISTRO_FEATURES has x11. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_3.3.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.3.2.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.3.2.bb
index 73213cc5a1..3c18367411 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.3.2.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.3.2.bb
@@ -88,6 +88,10 @@ EXTRA_OECONF = " \
--enable-pic \
--enable-shared \
--enable-pthreads \
+ --disable-libxcb \
+ --disable-libxcb-shm \
+ --disable-libxcb-xfixes \
+ --disable-libxcb-shape \
${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \
\
--cross-prefix=${TARGET_PREFIX} \
@@ -108,6 +112,7 @@ EXTRA_OECONF = " \
--datadir=${datadir}/ffmpeg \
${@bb.utils.contains('AVAILTUNES', 'mips32r2', '', '--disable-mipsdsp --disable-mipsdspr2', d)} \
--cpu=${@cpu(d)} \
+ --pkg-config=pkg-config \
"
EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"