aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJingdong Lu <jingdong.lu@windriver.com>2011-01-19 16:19:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:37:01 +0000
commit811a9f7a33c3cc6b51b59ef1f15d13edeb058eef (patch)
treee72e7d06594172644acb54b449e10c0f917481ba /meta
parent9da1e13e732313684159338279f8fb2ef8406056 (diff)
downloadopenembedded-core-811a9f7a33c3cc6b51b59ef1f15d13edeb058eef.tar.gz
qt4: Enable accessibility and sm option for LSB.
LSB library checks will look for some symbols of qt4 libraries. Enable "accessibility" and "sm" in order to pass the LSB test. Signed-off-by: Jingdong Lu<jingdong.lu@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/qmake2.bbclass1
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free_4.6.3.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4.inc10
3 files changed, 9 insertions, 4 deletions
diff --git a/meta/classes/qmake2.bbclass b/meta/classes/qmake2.bbclass
index 37721898d6..5eebd8ec42 100644
--- a/meta/classes/qmake2.bbclass
+++ b/meta/classes/qmake2.bbclass
@@ -19,5 +19,6 @@ export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/qt4"
export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
export OE_QMAKE_LIBS_QT = "qt"
export OE_QMAKE_LIBS_X11 = "-lXext -lX11 -lm"
+export OE_QMAKE_LIBS_X11SM = "-lSM -lICE"
export OE_QMAKE_LRELEASE = "${STAGING_BINDIR_NATIVE}/lrelease4"
export OE_QMAKE_LUPDATE = "${STAGING_BINDIR_NATIVE}/lupdate4"
diff --git a/meta/recipes-qt/qt4/qt4-x11-free_4.6.3.bb b/meta/recipes-qt/qt4/qt4-x11-free_4.6.3.bb
index 0a03e9b5a3..f13b94769f 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free_4.6.3.bb
+++ b/meta/recipes-qt/qt4/qt4-x11-free_4.6.3.bb
@@ -1,7 +1,7 @@
require qt4-x11-free.inc
require qt-4.6.3.inc
-PR = "r1"
+PR = "r2"
QT_CONFIG_FLAGS += " -xrandr "
diff --git a/meta/recipes-qt/qt4/qt4.inc b/meta/recipes-qt/qt4/qt4.inc
index 16d5bebd36..33824456ff 100644
--- a/meta/recipes-qt/qt4/qt4.inc
+++ b/meta/recipes-qt/qt4/qt4.inc
@@ -5,11 +5,15 @@ DEPENDS += "qt4-tools-native freetype jpeg libpng zlib dbus openssl glib-2.0 gst
inherit qmake_base
-QT_CONFIG_FLAGS += "-release -no-cups -no-accessibility -reduce-relocations \
- -shared -no-nas-sound -no-sm -no-nis \
+QT_DISTRO_FLAGS ?= "-no-accessibility -no-sm"
+QT_DISTRO_FLAGS_poky-lsb = "-sm"
+
+QT_CONFIG_FLAGS += "-release -no-cups -reduce-relocations \
+ -shared -no-nas-sound -no-nis \
-qt-gif -system-libjpeg -system-libpng -system-zlib \
-no-sql-ibase -no-sql-mysql -no-sql-psql -no-sql-odbc -plugin-sql-sqlite \
- -no-pch -dbus -stl -glib -phonon -webkit"
+ -no-pch -dbus -stl -glib -phonon -webkit \
+ ${QT_DISTRO_FLAGS} "
EXTRA_OEMAKE = "-e"