aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-08-16 14:34:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-19 11:24:51 +0100
commitfd9e591f266e1a6c183e77f24e50d31e0d52bdd5 (patch)
treeceb15e16d46d4f21582b71397b6ac5ec57bdc5ec /meta
parentb8952942aed77473d3b44a17112cbf6a9e83eff3 (diff)
downloadopenembedded-core-fd9e591f266e1a6c183e77f24e50d31e0d52bdd5.tar.gz
cronie: fix out of tree build
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/cronie/cronie/fix-out-of-tree-build.patch31
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.11.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie/fix-out-of-tree-build.patch b/meta/recipes-extended/cronie/cronie/fix-out-of-tree-build.patch
new file mode 100644
index 0000000000..7384a0bad4
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie/fix-out-of-tree-build.patch
@@ -0,0 +1,31 @@
+For an out of tree build, the cronie-common.h file was not being
+found correctly, so point it to the top_srcdir
+
+Upstream-Status: Submitted
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: cronie-1.4.11/anacron/Makefile.am
+===================================================================
+--- cronie-1.4.11.orig/anacron/Makefile.am
++++ cronie-1.4.11/anacron/Makefile.am
+@@ -9,6 +9,7 @@ common_nodist = anacron-paths.h
+ nodist_anacron_SOURCES = $(common_nodist)
+ BUILT_SOURCES = $(common_nodist)
+
++AM_CFLAGS = -I$(top_srcdir)
+
+ LDADD = $(LIBSELINUX) $(LIBPAM) $(LIBAUDIT)
+
+Index: cronie-1.4.11/src/Makefile.am
+===================================================================
+--- cronie-1.4.11.orig/src/Makefile.am
++++ cronie-1.4.11/src/Makefile.am
+@@ -15,6 +15,7 @@ nodist_crond_SOURCES = $(common_nodist)
+ nodist_crontab_SOURCES = $(common_nodist)
+ BUILT_SOURCES = $(common_nodist)
+
++AM_CFLAGS = -I$(top_srcdir)
+
+ LDADD = $(LIBSELINUX) $(LIBPAM) $(LIBAUDIT)
+
diff --git a/meta/recipes-extended/cronie/cronie_1.4.11.bb b/meta/recipes-extended/cronie/cronie_1.4.11.bb
index 5b124482a3..aa1ba39346 100644
--- a/meta/recipes-extended/cronie/cronie_1.4.11.bb
+++ b/meta/recipes-extended/cronie/cronie_1.4.11.bb
@@ -19,6 +19,7 @@ RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '',
PAM_DEPS = "libpam libpam-runtime pam-plugin-access pam-plugin-loginuid"
SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
+ file://fix-out-of-tree-build.patch \
file://crond.init \
file://crontab \
${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"