aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:41 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commitc48f87a3fa9c61aaeedbcf5712a699c27d940a3b (patch)
treec6f819254006c0b651d3a9b3cd9017e42ee74430 /meta
parent738005f4713c0da7bc04582a41efa956efdb9cc0 (diff)
downloadopenembedded-core-c48f87a3fa9c61aaeedbcf5712a699c27d940a3b.tar.gz
qemu-config: split out export of root via NFS to its own recipe
This need not be specific to qemu machines, allow it to be used elsewhere in isolation. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb7
-rw-r--r--meta/recipes-devtools/devel-config/nfs-export-root.bb17
-rw-r--r--meta/recipes-devtools/devel-config/nfs-export-root/exports (renamed from meta/recipes-bsp/qemu-config/qemu-config/exports)0
3 files changed, 19 insertions, 5 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index 06f2f326b4..3ed07df91a 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -9,18 +9,15 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
PR = "r25"
-SRC_URI = "file://distcc.sh \
- file://exports"
+SRC_URI = "file://distcc.sh"
S = "${WORKDIR}"
do_install() {
install -d ${D}${sysconfdir}/profile.d
-
install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
- install -m 0644 exports ${D}${sysconfdir}/
}
-RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
+RDEPENDS_${PN} = "distcc oprofileui-server bash"
inherit allarch
diff --git a/meta/recipes-devtools/devel-config/nfs-export-root.bb b/meta/recipes-devtools/devel-config/nfs-export-root.bb
new file mode 100644
index 0000000000..41259acfb3
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/nfs-export-root.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Enables NFS access from any host to the entire filesystem (for development purposes)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://exports"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 exports ${D}${sysconfdir}/
+}
+
+RDEPENDS_${PN} = "task-core-nfs-server"
+
+inherit allarch
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/exports b/meta/recipes-devtools/devel-config/nfs-export-root/exports
index b7257aa008..b7257aa008 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config/exports
+++ b/meta/recipes-devtools/devel-config/nfs-export-root/exports