aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJesse Zhang <sen.zhang@windriver.com>2013-06-24 09:44:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:43:41 +0100
commita825781fc822f4630bc29906ca1ca79b8fad4836 (patch)
treed264e7110d2f4fcf86ad9a620b128a8e0df2645c /meta
parent374b9c37b3310cf2a3373633197ca7ba21f6d1bd (diff)
downloadopenembedded-core-a825781fc822f4630bc29906ca1ca79b8fad4836.tar.gz
gst-ffmpeg: fix libav config error for ppc
Pass --cpu to libav config when we're building ppc, or else there are errors like: You need a compiler that supports {} in AltiVec vector declarations. Also patch libav configure to have knowledge of more ppc CPUs. Signed-off-by: Jesse Zhang <sen.zhang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/libav_e5500.patch19
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb7
2 files changed, 25 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/libav_e5500.patch b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/libav_e5500.patch
new file mode 100644
index 0000000000..d9ea2c29e0
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-ffmpeg-0.10.13/libav_e5500.patch
@@ -0,0 +1,19 @@
+libav: Add configs for ppc e5500
+
+Upstream-Status: Pending
+
+Signed-off-by: Jesse Zhang <sen.zhang@windriver.com>
+
+--- gst-ffmpeg-0.10.13/gst-libs/ext/libav/configure 2013-06-20 05:18:36.073104964 -0400
++++ gst-ffmpeg-0.10.13/gst-libs/ext/libav/configure 2013-06-20 05:18:38.269104150 -0400
+@@ -2222,6 +2222,10 @@
+ cpuflags="-mcpu=8540 -mhard-float"
+ disable altivec
+ ;;
++ e5500)
++ cpuflags="-mcpu=e5500 -mhard-float"
++ disable altivec
++ ;;
+ esac
+
+ elif enabled x86; then
diff --git a/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb b/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
index 2107704618..8605ca46b9 100644
--- a/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
@@ -21,6 +21,7 @@ SRC_URI = "http://gstreamer.freedesktop.org/src/${BPN}/${BPN}-${PV}.tar.bz2 \
file://configure-fix.patch \
file://h264_qpel_mmx.patch \
file://libav_e500mc.patch \
+ file://libav_e5500.patch \
"
SRC_URI[md5sum] = "7f5beacaf1312db2db30a026b36888c4"
@@ -31,7 +32,11 @@ PR = "r4"
GSTREAMER_DEBUG ?= "--disable-debug"
FFMPEG_EXTRA_CONFIGURE = "--with-ffmpeg-extra-configure"
-FFMPEG_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux \
+# pass --cpu for powerpc. get cpu name by stripping "ppc" or "ppc64"
+# from DEFAULTTUNE
+FFMPEG_CPU_powerpc = "--cpu=${@d.getVar('DEFAULTTUNE')[3:]}"
+FFMPEG_CPU_powerpc64 = "--cpu=${@d.getVar('DEFAULTTUNE')[5:]}"
+FFMPEG_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux ${FFMPEG_CPU} \
--cc='${CC}' --as='${CC}' --ld='${CC}' --nm='${NM}' --ar='${AR}' \
--ranlib='${RANLIB}' \
${GSTREAMER_DEBUG}"